ERROR

Layer cannot be added. Failed to load service: 500

Last Published: April 25, 2020

Error Message

Note: 
This has been fixed in ArcGIS Enterprise Version 10.6.1.

Attempting to load a scene layer in Portal for ArcGIS Scene Viewer, or sharing a scene layer from Drone2Map for ArcGIS to ArcGIS Enterprise installed on Windows Server 2016, fails with the following error:

Error:   
Layer cannot be added. Failed to load service: 500
image of error on a map

Similar behavior occurs when attempting to load a scene layer shared from ArcGIS Pro to ArcGIS Enterprise installed on Windows Server 2016, and returns the following error:

Error:   
Scene service is missing root node

Cause

When creating scene services, ArcGIS Server must communicate with ArcGIS Tile Cache Data Store. ArcGIS Data Store tile cache components use CouchDB to create the scene's cache. The CouchDB requires client connections made using SSL 3.0. This issue occurs when to the SSL 3.0 requirement is disabled on Window Server 2016 resulting in ArcGIS Server being unable to communicate with ArcGIS Data Store.

Solution or Workaround

Esri recommends upgrading to ArcGIS Enterprise 10.6.1 or later. If this is not feasible, there are two ways to resolve this issue depending on communication requirements:

Enable SSL 3.0

To enable communication between ArcGIS Server and ArcGIS Data Store, enable SSL 3.0 by following steps in the article: Problem: When publishing hosted scene layers from ArcGIS Pro, the Jobs Status tab shows that caching has failed without any error message.

Use HTTP communication

Configure the tile cache data store to use HTTP communication with the hosting server. This action does not require SSL 3.0 to be enabled on the hosting server machines. Use the changedbproperties.bat data store command line utility with the EnableSSL parameter set to "none".

  1. In Windows, click the Start button, and type cmd in the Search programs and files box to open a Command Prompt window.
  2. Right-click cmd.exe, and click Run as Administrator on the server where ArcGIS Data Store installed.
  3. Navigate to: C:\ProgramFiles\ArcGIS\DataStore\tools:
    cd C:\ProgramFiles\ArcGIS\DataStore\tools
  4. Run the changedbproperties.bat utility with the following command:
    changedbproperties.bat --store tileCache --enablessl none 

For more information, refer to ArcGIS Data Store command utility reference.

Article ID:000017949

Software:
  • Portal for ArcGIS
  • ArcGIS Server
  • ArcGIS Drone2Map

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic