English

Problem: Data Interoperability has incompatibilities when more than one Data Interoperability product is on a single machine

Description

When more than one Data Interoperability product is installed on a single machine, there are known issues with the compatibility and functionality of the Data Interoperability installation. Documented in this technical article are a list of install sequences of the Data Interoperability products, the problem that occurs, and the workaround for the issue.

Installed FirstInstalled SecondProblem
ArcGIS Data Interoperability 10.6 for DesktopData Interoperability for ArcGIS Pro 2.1ArcGIS Data Interoperability 10.6 for Desktop Quick Import/Export dialog script error in MdDlgContent.htm
ArcGIS Data Interoperability 10.6 for DesktopData Interoperability for ArcGIS Pro 2.1ArcGIS Data Interoperability 10.6 for Desktop Interoperability connections can be created but do not work
Data Interoperability for ArcGIS Pro 2.1ArcGIS Data Interoperability 10.6 for DesktopData Interoperability for ArcGIS Pro 2.1 Quick Import input dataset picker cannot browse
Data Interoperability for ArcGIS Pro 2.1ArcGIS Data Interoperability 10.6 for DesktopData Interoperability for ArcGIS Pro 2.1 Quick Export output dataset picker cannot browse
Data Interoperability for ArcGIS Pro 2.1ArcGIS Data Interoperability for Server for 10.6ArcGIS Data Interoperability for Server for 10.6 fails to publish Spatial ETL tools

Cause

Esri is aware of the underlying cause of these issues and is working to get them fixed.

Solution or Workaround

Until a permanent fix for these issues becomes available, Esri recommends the workaround listed below. 

First / SecondWorkaround

ArcGIS Data Interoperability 10.6 for Desktop / 

Data Interoperability for ArcGIS Pro 2.1

Perform a repair install of ArcGIS Data Interoperability 10.6 for Desktop.

ArcGIS Data Interoperability 10.6 for Desktop / 

Data Interoperability for ArcGIS Pro 2.1

Perform a repair install of ArcGIS Data Interoperability 10.6 for Desktop.

Data Interoperability for ArcGIS Pro 2.1 / 

ArcGIS Data Interoperability 10.6 for Desktop

Perform a repair install of Data Interoperability for ArcGIS Pro 2.1.

Data Interoperability for ArcGIS Pro 2.1 / 

ArcGIS Data Interoperability 10.6 for Desktop

Perform a repair install of Data Interoperability for ArcGIS Pro 2.1.

Data Interoperability for ArcGIS Pro 2.1 / 

ArcGIS Data Interoperability for Server for 10.6

No workaround for side-by side-operation exists. Uninstall ArcGIS Data Interoperability for Server 10.6.