Description
Attempts to publish a service to Portal for ArcGIS fail and the following error message is returned:
Error:
No hosting server found.
Cause
There are two possible causes to the problem:
- The user account has insufficient privileges to publish a service. For example, a level 1 account can only access available services. A level 2 account has publishing and editing privileges.
- The Web Adaptor configured to the server hosting Portal for ArcGIS references the URL inaccurately. The default URL is generally in the following format:
https://<FQDN>/<web adaptor name>
However, inaccurate configurations may reference a different URL, for example:
https://<FQDN>/<web adaptor name>/rest
Solution or Workaround
Depending on the cause, use one of the following solutions to rectify the error:
- Ensure the user account has sufficient privileges before accessing the portal. For more information, refer to the following web help document, Portal for ArcGIS: Levels, roles, and privileges.
- Update the URL to the main Portal for ArcGIS page, https://<FQDN>/<web adaptor name>. The following procedure demonstrates how to update the URL using the Portal for ArcGIS REST endpoint.
Note:
Only those with the Administrator privileges may perform the following steps.
- Log in to ArcGIS Portal Directory REST endpoint using an administrator account, and click Home.
- Under Home, browse to Child Resources and click Portals.
- Under Portals Root, browse to Child Resources and click Self.
- Under Self, scroll down the page and click Servers.
- Under Servers, browse and click the desired Server Id.
- Once the Server Id is determined, click Update Server. This opens the Update Server page.
- Under Update Server, change the URL to match the main Portal for ArcGIS page. Click Update. The URL is updated.