PROBLEM

Unable to log into ArcGIS Enterprise portal with ArcGIS Collector when using a self-signed certificate

Last Published: July 20, 2023

Description

When using a self-signed certificate, users are unable to log in to an ArcGIS Enterprise portal with ArcGIS Collector.

Cause

Starting with ArcGIS Collector version 17.0.3, self-signed and untrusted certificates are no longer supported. This change was made due to security concerns. Thus, customers that use self-signed and untrusted certificates for testing must update their certificates.

Solution or Workaround

Without additional cost, there are a few ways to resolve this issue.

  • Use a wildcard certificate
    If the production and testing environments are on the same domain, a wildcard certificate can be used to cover both environments. For example, if on the domain mydomain.com, the Common Name (CN) is *.mydomain.com and the Subject Alternative Name (SAN) is also *.mydomain.com. If the certificate authority used does not accept wildcards for the SAN, the CN for each host can be provided as a SAN.
  • Use a free certificate
    Some certificates are free, and these are also supported. For example, Let’s Encrypt! or Comodo are free options.

Article ID:000017061

Software:
  • ArcGIS Collector
  • Portal for ArcGIS

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