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Problem: Making an Oracle connection in Insights for ArcGIS results in an error

Description

Connecting Insights for ArcGIS to databases requires the portal's hosting server site to have relational data store types registered for use. For each supported database, a vendor file containing Java Database Connectivity (JDBC) drivers must be downloaded from the vendor site, and added to the uploads page from the server admin endpoint. When the drivers are uploaded, the data store type is registered. Restarting ArcGIS Server windows service is required to update the changes.

In some instances, after completing the steps mentioned above, a connection to Oracle still is not successful, and returns the following error:

Error:   
Something went wrong.
This error indicates issues with the installation of the drivers as opposed to an incorrect connection property, which gives a more specific description of the error.

Cause

The following are possible causes for this issue:

  • The downloaded vendor file, Oracle Spatial and Graph (Spatial Java Class API) contains an additional file called, sdotype, which is no longer recommended to be included with Insights for ArcGIS.
  • In some instances, when registering relational data store types, in addition to restarting ArcGIS Server after uploading and registering the drivers, the Portal for ArcGIS service must also be restarted to ensure successful connection.

Solution or Workaround

  1. Download the required vendor files, which exclude the sdotype file, or download Oracle Spatial and Graph (Spatial Java Class API), and remove the sdotype file and re-zip the ojbdc.jar file with the sdoapi.jar and sdoutl.jar files. For required vendor files for Oracle connections, refer to Insights for ArcGIS: Supported databases
  2. Upload and register the data store types. For more information, refer to Insights for ArcGIS: Register relational data store types.
  3. Restart both ArcGIS Server and Portal for ArcGIS Windows services. To do this, follow the steps provided below:
    1. Search for services.msc from the Start menu, and click Services.
    2. In the Services window, right-click ArcGIS Server > Restart. Repeat for the Portal for ArcGIS service.
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