English

How To: Use 3D shapes as marker symbols in ArcGIS Pro scene view

Summary

3D symbols are categorized under the marker symbol layers known as 3D model marker symbol layers. 3D model marker symbol layers are mainly used to emphasize symbols especially point symbols on map. They can be used to identify locations, routes or transportation utilized in an area symbolized in 3D form. The model for these markers can be derived from either built-in 3D symbols or custom 3D symbols to ArcGIS Pro.

Procedure

The instructions provided describe two methods that show how to use 3D shapes as marker symbols in the ArcGIS Pro scene view, either by using built-in symbols, or importing custom symbols.

Note:
Some layers are displayed as 2D layers in a scene by default. To apply 3D symbology to a layer, ensure the desired point file is moved to the 3D Layers group in the Contents pane. For more information, refer to ArcGIS Pro Web App: Make a 3D scene: Add 3D symbology to 2D layers.
The picture shows the location of the point symbol in the 3D Layers group
 
Using built-in 3D symbols
  1. Click the symbol of the desired point layer in the Contents pane to open the Symbology pane.
    Note:
    It is also possible to right-click the point layer in the Contents pane > Symbology to open the Symbology pane.


     
  2. Click the ArcGIS 3D drop-down arrow to view the common 3D symbols.
    Note:
    Most of the built-in 3D symbols are turned off by default upon first opening of ArcGIS Pro.

    The picture shows the ArcGIS 3D drop-down arrow
     
  3. To add more built-in 3D symbols, follow the steps below:
    1. Click the Insert tab > Add Style > Add System Styles.

      The picture shows the Insert tab, Add Style drop-down arrow and Add System Style
       
    2. Click the 3D drop-down arrow and check the desired 3D symbol boxes in the System Styles dialog box. Click OK.

      The picture shows the System Styles dialog box and the OK option
  4. Select the desired 3D symbol to add in ArcGIS Pro.
Importing custom 3D symbols
Note:
ArcGIS Pro only supports COLLADA (.dae), 3ds Max (.3ds), OpenFlight (.flt), and Wavefront (.obj) models for custom 3D symbols. Users can download these files from websites or create the files in other software.
  1. Click the symbol of the desired point layer to open the Symbology pane. 
  2. Click Properties > the Layers icon.
    Note:
    Ensure the box that lies under the Layers icon is checked to enable viewing of the 3D symbol at the bottom of the Symbology pane. 
    Other settings can be changed as well. For more information, refer to ArcGIS Pro Web Help: Modify symbol layers.

    The picture shows the Layer icon and the box to be checked
     
  3. Click the drop-down arrow below the Layers icon to change the marker type. Select 3D model marker.
  4. In the Appearance section, click the File button.

    The picture shows the Properties tab, Layer tab and File option.
     
  5. In the Browse 3D model file dialog box, select the desired custom symbol file, and click OK.

    The picture shows the Browse 3D model file dialog box and the OK option

Related Information