PROBLEM

Displaying data in web applications fails with error code 103900

Last Published: April 25, 2020

Description

When attempting to display data in a web application, for example Web AppBuilder for ArcGIS, and printing the map using the Print widget, the print results fail to display any data and return a Layer Drawing Error. The following example shows how the error may appear in the ArcGIS Server Manager log:

Image of typical error in the ArcGIS Server Manager Error log

In the raw log file located in the folder, C:\arcgisserver\logs\<User>\server, the error may appear as follows:

Error:
<Msg time='2014-12-10T10:56:34,672' type='SEVERE' code='103800' target='servicename.MapServer' methodName='DrawGraphicCursor.NextGraphic' machine='abc' process='32624' thread='30964' user='anonymous' >There is an error during the draw abc (1.) Out of server memory [scheme,(2.) layername].</Msg>

Cause

There are two possible causes for the drawing error:

  • A syntax error in the query request. If a syntax error is present, the error presents itself as the first sample error in the ArcGIS Server Manager logs.
  • The ArcGIS Server machine experienced a resources issue.

Solution or Workaround

Use one of the following options to solve this issue:

  • Ensure the correct syntax and schemas are used for the query request.
  • Identify and remove any corrupted Esri resources. For more information, refer to the following web help document: ArcGIS Server: Analyze your GIS resource.

Article ID:000016601

Software:
  • Web Applications
  • ArcGIS Server

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic