PROBLEM

Unable to access ArcGIS Insights

Last Published: February 24, 2022

Description

When accessing ArcGIS Insights from Portal for ArcGIS versions 10.6 and below, the following message is returned:

Error:   
You're about to be redirected to Portal... 
Sorry, you don't have permission to access Insights for ArcGIS. Contact your ArcGIS administrator for access privileges.
Error message
Note:
The steps included in this article apply to ArcGIS Enterprise version 10.6.x and prior releases.

Cause

  • The ArcGIS Insights license in Portal for ArcGIS is not assigned to the end users.
  • The ArcGIS Insights license in Portal for ArcGIS is assigned to a Level 2 user without the Publisher role.

Solution or Workaround

To resolve this issue, follow the instructions described below.

  1. Log in to Portal for ArcGIS with an ArcGIS Enterprise username and password.
  2. Assign the Level 2 end user a Publisher role. For instructions, refer to Portal for ArcGIS: Configure roles.
  3. After assigning the Level 2 end user the Publisher role, click Organization > MANAGE LICENSES.
Organizations tab
  1. In the Members section, select the desired Level 2 user and click Configure licenses.
Note:
Optionally, use the Search by drop-down option to filter and select the user. In this case, check the Level 2 button.
Configure licenses
  1. Check the Insights for ArcGIS check box and click ASSIGN to assign the license to the end user.
Assign option

Article ID:000016197

Software:
  • Portal for ArcGIS
  • ArcGIS Insights

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic