ERROR

External sharing process failed

Last Published: April 25, 2020

Error Message

Attempting to publish a shapefile to ArcGIS Online via ArcGIS Pro returns the following error message.

Error:   
External sharing process failed
Image of the error message

Cause

This error occurs due to the installation of Python with ArcGIS Pro. At version 1.3, Python is installed along with ArcGIS Pro; this removes the requirement for a secondary installation of Python for ArcGIS Pro to run stand-alone Python Scripts. In some instances, multiple versions of Python with different environments, such as 32-bit or 64-bit, can be installed on the same machine. The PYTHONPATH environment variable overwrites the PATH variable, which designates which version of Python to use. For more information, refer to FAQ: Why do Python scripts fail on a machine with both ArcGIS for Server and Desktop installed?

Note:
Prior to ArcGIS Pro version 1.3, Python can be installed as a standalone program. 

Solution or Workaround

Depending on the cause, select one of the options below to resolve the issue.

Warning:   
The instructions below include making changes to essential parts of your operating system. It is recommended that you backup your operating system and files, including the registry, before proceeding. Consult with a qualified computer systems professional, if necessary. 

Esri cannot guarantee results from incorrect modifications while following these instructions. Therefore, use caution and proceed at your own risk.
  • Remove the Python PATH environment variable

    This workaround can be performed without uninstalling ArcGIS Pro.

    1. In Windows, click Start > right-click My Computer > Properties > Advanced System Settings > Environment Variables.
    2. In the Environment Variables window, look for PYTHON or PYTHONPATH in the System Variables tab.
    3. Delete the variables PYTHON and PYTHONPATH. This removes the Python PATH environment variable.
    Note:
    Removing both variables may hamper Python functionality in ArcMap, but not for ArcGIS Pro.
    
  • Launch ArcGIS Pro with a batch script

    In the event that the system variables cannot be removed due active application dependency on the same machine as ArcGIS Pro, launch ArcGIS Pro with a batch file using the following syntax:

    SET PYTHONPATH="" START "" "C:\Program Files\ArcGIS\Pro\bin\ArcGISPro.exe"
    
  • Publish directly to ArcGIS Online
    1. Zip the shapefile using a file compression software, such as WinZip.
    2. Log in to www.arcgis.com.
    3. Navigate to My Content.
    4. Click Add Item > From my computer.
    5. Select the zipped shapefile, and add a name and the necessary tags. Click Add Item.
  • Uninstall and reinstall ArcGIS Pro

    If the aforementioned workarounds do not work, perform a clean uninstallation and reinstallation of ArcGIS Pro. This workaround is an alternative if removing the Python PATH environment variable does not resolve the error.

    1. Uninstall ArcGIS Pro via the Windows Control Panel. For steps on how to do so, refer to ArcGIS Help: Uninstalling ArcGIS Pro.
      Note:
      If the uninstallation process fails, stop all active ArcGIS Pro processes via the Task Manager before reattempting uninstallation. 
      
    2. Once ArcGIS Pro is uninstalled, delete the remaining ArcGIS Pro files commonly found in the following locations:
      C:\Users\<username>\AppData\Local\ESRI\ArcGISPro 
      (and any other Pro folders)
      C:\Users\<username>\AppData\Roaming\ESRI\ArcGISPro
      C:\Program Files\ArcGIS\Pro
      C:\ProgramData\Microsoft\Windows\StartMenu\Programs\ArcGIS\ArcGIS Pro
      Note:
      Some of the folders above may be hidden. To show hidden folders, refer to Windows Help: Show hidden files.
    3. Search and delete the following registry keys:
      HKEY_CURRENT_USER\Software\ESRI\ArcGIS Online For Pro
      HKEY_CURRENT_USER\Software\ESRI\ArcGISPro
      HKEY_CURRENT_USER\Software\ESRI\ArcGISPro1.0
      Warning:
      Esri does not support modifications done to the registry of the operating system.
      
    4. Reboot the machine, and reinstall ArcGIS Pro.

Article ID:000015162

Software:
  • ArcGIS Pro

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