PROBLEM

Comments do not display in the Crowdsource Reporter application

Last Published: April 25, 2020

Description

Crowdsource Reporter is an application template for ArcGIS for Local Government, and is also available as a configurable template in ArcGIS Online. The application template allows managers to collect user input, such as reports, comments, and votes, from a variety of mobile devices as well as desktop computers.

In some instances, comments do not display in the Crowdsource Reporter application but are viewable in the attribute table.

Cause

This issue occurs when the relationship class between the feature class and the comment table is not configured properly or is missing altogether.

Solution or Workaround

A related table is required to collect and store comments from users of the Crowdsource application. The related table must participate in a relationship class, as this is the only type of relationship supported in ArcGIS Online.
Note: 
An ArcGIS for Desktop Standard or Advanced license is required to create a relationship class.
  1. In ArcMap, create a table with a comment field set to String data type, and connect to the desired feature class based on a common unique identifier, such as Global IDs (GUIDs).
  2. Add the table and its associated feature class to the map.
  3. Publish the map to ArcGIS Online.
When creating the relationship class, GUIDs can be used as the primary key. It is not recommended to use ObjectIDs (OIDs) as the primary key. To create the relationship class based on GUIDs, use the Add Global ID (Data Management) tool in ArcMap to create a GUID field for the feature class. Then, in the table to be related which stores the comments, create a field of type GUID, using any workflow to add a field in ArcMap.

Article ID:000014151

Software:
  • Portal for ArcGIS
  • ArcGIS Online
  • ArcGIS for Local Government

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic