PROBLEM

Deleting a geodatabase version returns the error, "Target state not found in the STATES table"

Last Published: April 25, 2020

Description

When attempting to delete a version of the geodatabase, the following generic error message is returned:

Error:   
Target state not found in the STATES table.

Cause

This issue occurs when the delta tables in the geodatabase are corrupted.

Solution or Workaround

Esri provides geoprocessing tools to identify inconsistencies within the versioning system tables of a versioned geodatabase, as described below.

Note:
Prior to running any repair tool, ensure the user is connected as a geodatabase administrator. Only a geodatabase administrator has the privileges to run the repair tools.
  1. Run the Diagnose Version Tables tool to check if there are any inconsistencies with the geodatabase tables.
    1. In Catalog, navigate to System Toolboxes > Data Management Tools > Geodatabase Administration > Diagnose Version Tables.
    2. In the Diagnose Version Tables window, assign the desired input database connection and the diagnose version tables log location, and click OK.
  2. Run the Repair Version Tables tool to address any inconsistencies from Step 1.
    1. In Catalog, navigate to System Toolboxes > Data Management Tools > Geodatabase Administration > Repair Version Tables.
    2. In the Repair Versions Tables window, assign the desired input database connection and the repair versions tables log, and click OK.
  3. Run the Diagnose Version Metadata tool to check if there are any inconsistencies within the versioning system tables of a versioned geodatabase.
    1. In Catalog, navigate to System Toolboxes > Data Management Tools > Geodatabase Administration > Diagnose Version Metadata.
    2. In the Diagnose Version Metadata window, assign the desired input database connection and the metadata logfile output location, and click OK.
  4. If there are any inconsistencies in the versioning system tables of the versioned geodatabase, run the Repair Version Metadata tool.
    1. In Catalog, navigate to System Toolboxes > Data Management Tools > Geodatabase Administration > Repair Version Metadata.
    2. In the Repair Version Metadata window, assign the desired input database connection and the logfile output, and click OK.

Article ID:000013519

Software:
  • ArcMap

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