PROBLEM

Unable to reset the path of a mosaic dataset

Last Published: September 21, 2023

Description

Attempting to repair a mosaic dataset data source in ArcMap using the Repair Mosaic Dataset Paths tool or the Repair Mosaic Dataset dialog box fails to reset the path.

Cause

This issue may occur due to one of the following reasons:

  • The mapped network drive is altered by the network administrator; hence, the map drive is unable to connect when using the Repair Mosaic Dataset tool (for example, \\ServerA\CityData\Rasters is changed to \\ServerA\CityData\Images).
  • There is a change in the file name or file extension.
  • The geodatabase containing the mosaic dataset was moved, and old lock files remain in the geodatabase.

Solution or Workaround

If the mosaic dataset is moved and renamed in the mapped network drive

  1. Create a new empty mosaic dataset.
  2. Add the rasters to the mosaic dataset using the Add Raster To Mosaic Dataset tool.
  3. In the Catalog window, right-click the mosaic dataset > Optimize > Build Overviews.
    Note:
    Additionally, add the footprints from the previous mosaic dataset using the Import Mosaic Dataset Geometry tool. For more information on mosaic dataset footprints, refer to the following ArcGIS Web Help topic, Mosaic dataset footprints.

If the mosaic dataset is referring to the images of an external dataset

  1. Remove the primary raster and overview from the dataset by right-clicking the raster in the Catalog window > Remove.
  2. Add the raster from the new location by right-clicking the raster in the Catalog window, and click Add Rasters.
  3. Rebuild the overviews by right-clicking the raster in the Catalog window > Optimize > Build Overviews.

    For more information on mosaic dataset overviews, refer to the following ArcGIS Web Help topic, Mosaic dataset overviews.
    Note:
    Use Universal Naming Convention (UNC) paths when repairing mosaic datasets. For more information on using UNC paths, refer to the following documentation, Paths explained: Absolute, relative, UNC, and URL.

If the mosaic dataset was moved and lock files remain in the geodatabase

  1. Close any ArcGIS Pro projects containing the mosaic dataset.
  2. In Windows File Explorer, navigate to the geodatabase containing the mosaic dataset.
  3. Delete any lock files older than the current date from the geodatabase.
  4. Run the Repair Mosaic Dataset Paths tool.

Article ID:000012878

Software:
  • ArcMap

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic