English

How To: Find raster value differences between two rasters in ArcMap

Summary

Spatial analysis tools such as the Raster Calculator and Minus tools can provide powerful insights on raster value differences between raster images that are geographically overlapping. In ArcGIS Desktop, these tools are located in the Spatial Analyst toolbox. Alternatively, environments without the ArcGIS Spatial Analyst extension can use the Difference function from the Image Analysis window.

Procedure

Note:
The Raster Calculator and Minus tools require a Spatial Analyst license.

The instructions provided describe the steps to find raster value differences between two rasters. Option A describes the workflow when using the Raster Calculator tool from the Map Algebra toolset, whereas Option B describes the workflow when using the Minus tool from the Math toolset. Option C describes the steps to find the raster value differences using the Difference tool from the Image Analysis window, which does not require an extension.

  • Option A: Use Raster Calculator
  1. In ArcMap, navigate to ArcToolboxSpatial Analyst Tools > Map Algebra > Raster Calculator.
  2. In the Raster Calculator window, double-click one of the rasters to be analysed, click the minus sign (-), and double-click the second raster.
  3. Specify the name and location for the output raster.
  4. Click OK.
User-added image
 
  • Option B: Use the Minus tool
  1. In ArcMap, navigate to ArcToolboxSpatial Analyst Tools > Math > Minus.
  2. Drag and drop the rasters to be analyzed, or specify the rasters by clicking the folder icon to select the rasters for the Input raster or constant value 1 and Input raster or constant value 2 fields.
  3. Specify the name and location for the output raster.
  4. Click OK.
Image of the Math tool
 
  • Option C: Use the Difference function
  1. To open the Image Analysis window, in ArcMap, click Windows on the main menu, and click Image Analysis.
  2. Click the desired two layers in the Image Analysis window.
  3. Click the Difference button Difference. This creates a temporary layer showing the differences between the rasters.
Image Analysis Window
  1. To save the layer from Step 3, right-click the layer, and navigate to Data > Export Data. Select the location and assign a name for the output raster dataset, and click Save.
Export raster
Note:
Ensure the pixel size and projections of both rasters are the same. If necessary, use the Resample and Project Raster tools from the Data Management toolbox to change the pixel size and projection of the rasters respectively. To ensure the accuracy of the output raster, the extents of the rasters can be aligned using the Clip tool.

Related Information