PROBLEM

Requests to ArcGIS Server via a web adaptor installed on Oracle WebLogic takes 20 seconds or longer to complete

Last Published: March 12, 2021

Description

When accessing ArcGIS Server resources through a web adaptor that has been set up on an Oracle WebLogic web server, requests take 20 seconds or longer, and sometimes do not complete.

Cause

An issue within the WebLogic web server causes cached requests to stop responding.

Solution or Workaround

Oracle's suggested fix for this problem is to change the SSL implementation used internally within WebLogic. In most cases this will fix the issue regardless of whether the requests are being made via HTTPS.

Warning:
The following steps are not fully supported by Esri, as technically the change is being made to the Oracle WebLogic server.
  1. Go to the Admin Console for the WebLogic server
  2. Navigate to Home > Summary of Servers > [Server name] > Configuration, Server Start tab, where [Server name] is the name of the server where WebLogic is installed.
  3. Add the following to the Arguments section:
Code:
-DUseSunHttpHandler=true
  1. Restart the WebLogic server.

Article ID:000012799

Software:
  • ArcGIS Server

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