Problem: GeoPackage (.gpkg) is not visible in the Catalog view in ArcCatalog or ArcMap
Description
When navigating to a directory that contains GeoPackage (.gpkg) data, ArcCatalog/ArcMap do not display them.
Note: This article applies to retired ArcGIS versions 10.2.x. Later versions of ArcGIS may contain different functionality, as well as different names and locations for menus, commands and geoprocessing tools.
Cause
ArcGIS Desktop 10.2 has already been installed and Catalog used. Installing 10.2.1 or 10.2.2 does not show .gkpg files because the cache file is outdated.
Solution or Workaround
Delete the cache files (GxDBFactCache.dat, GxObjFactCache.dat) in:
%USERPROFILE%\AppData\Roaming\ESRI\Desktop10.2\ArcCatalog
This causes the cache files to be regenerated, and the .gpkg files are then visible.
Last Published: 1/26/2022
Article ID: 000012010
Software: ArcGIS for Desktop Advanced 10.2.1 ArcGIS for Desktop Basic 10.2.1 ArcGIS for Desktop Standard 10.2.1