ERROR

A problem occurred when Windows tried to activate. Error Code 0xC004F074

Last Published: April 25, 2020

Error Message

On Amazon EC2, the Windows OS expires and Windows OS activation fails with Error Code 0xC004F074.

Windows EC2 instances started from ArcGIS Server Amazon Machine Images (AMIs) for 10.1 and 10.1 SP1 return an error that the Windows OS is going to expire or that the user is not running a genuine version of Windows. The Windows OS activation may also fail with the following error message:

"A problem occurred when Windows tried to activate. Error Code 0xC004F074. For a possible resolution, click More Information. Contact your system administrator or technical support department for assistance."

Cause

There are two possible causes for this problem:

• Outbound traffic is blocked through port 1688 in the Windows Firewall.

• The EC2Config service running on the instance is not the latest version released by Amazon Web Services.

Solution or Workaround

The instructions provided describe how to resolve this problem by verifying that outbound connections are allowed and installing the latest EC2Config service.

Note:
If there is an SQL Server Geodatabase running on its own EC2 instance, apply the fix to that instance first.

For an SQL Server geodatabase running on its own dedicated EC2 instance in a site created from ArcGIS Server Cloud Builder

1. Log into the geodatabase instance. It is labeled as EGDBHOST in the AWS Management Console.

2. Check the Windows Firewall settings to verify that the outbound firewall is enabled.
A. Navigate to Start > Administrative Tools > Windows Firewall with Advanced Security. 

B. Click Windows Firewall Properties.

C. If outbound connections set to "Allowed (default)" proceed to step 4. If any profiles have blocked outbound connections proceed to step 3.

Figure 1: Windows Firewall Overview

[O-Image] Check Windows Firewall
3. If the outbound connections are blocked in any of the profiles, add port 1688 to the outbound rules.
A. Click Outbound Rules in the left panel. 

B. In the menu, navigate to Action > Port > Next > Type 1688 > Next > Select "Allow the connection" > Next > Next > Give a Name and Description (optional) > Finish.

C. Close the firewall window.

Figure 2: New Outbound Rule Wizard

[O-Image] Add port 1688
4. Download EC2Install.zip and unzip the file.

5. Run EC2Install.exe.

6. From the Windows Start menu, restart the machine.

7. Log into the machine, and verify that the EC2config service exists and starts in the Windows Services panel.

8. In a command line window, run "slmgr /ato". A pop-up window opens stating that Windows has been successfully activated.
Figure 3: The Windows Script Host message for a successful product activation.

[O-Image] Windows Script Host

For a single-machine site created from ArcGIS Server Cloud Builder

1. Log into the EC2 instance running ArcGIS Server. This instance is labeled as SITEHOST in the AWS Management Console.

2. Check the Windows Firewall settings. If the outbound connections are blocked in any of the profiles, add an outbound rule allowing port 1688, see Figure 1 and Figure 2.

3. Download EC2Install.zip and unzip the file.

4. Run EC2Install.exe.

5. From the Windows Start menu, restart the machine.

6. Log into the machine, and verify that the EC2config service exists and starts in the Windows Services panel.

7. In a command line window, run "slmgr /ato". A pop-up window opens stating that Windows has been successfully activated, see Figure 3.

8. Open ArcGIS Server Manager and click Site > Data Store.

9. Verify that registered data stores can be validated.

For EC2 instances created from ArcGIS Server Cloud Builder

1. In Cloud Builder, set the Number of Instances property to ‘2’ and uncheck ‘Enable Auto-scaling.’ The site now contains exactly two EC2 instances.

2. Log into the EC2 instance containing the ArcGIS for Server configuration store and server directories. This instance is labeled as SITEHOST in the AWS Management Console.

3. Check the Windows Firewall settings. If the outbound connections are blocked in any of the profiles, add an outbound rule allowing port 1688, see Figure 1 and Figure 2.

4. Download EC2Install.zip and unzip the file.

5. Run EC2Install.exe.

6. From the Windows Start menu, restart the machine.

7. Log into the machine, and verify that the EC2config service exists and starts in the Windows Services panel.

8. In a command line window, run "slmgr /ato". A pop-up window opens stating that Windows has been successfully activated, see Figure 3.

9. Open ArcGIS Server Manager and click Site > Data Store.

10. Verify that registered data stores can be validated.

11. Repeat the steps 2-9 on the second machine.

12. In ArcGIS Server Manager, click Site > Machines and verify that there are two machines in the site and that both are started.

13. Test and configure the site. Make sure it is working correctly.

14. In Cloud Builder, create a template from the newly fixed site. Use this template to launch a site with the desired number of EC2 instances and auto-scaling rules.

15. Switch the organization's address mapping to point at the fixed site's URL.

Note:
If any applications reference the site URL directly, update the URLs in these applications to incorporate the new Elastic Load Balancer (ELB) address. The ELB address can be found by referencing the Manager URL in Cloud Builder’s site details.

16. Verify that the new site works correctly.

17. Delete the original site. The new templates can also be deleted.

For an instance that was created with the AWS Management Console

1. Log into the EC2 instance.

2. Check the Windows Firewall settings. If the outbound connections are blocked in any of the profiles, add an outbound rule allowing port 1688, see Figure 1 and Figure 2.

3. Download EC2Install.zip and unzip the file.

4. Run EC2Install.exe.

5. From the Windows Start menu, restart the machine.

6. Log into the machine, and verify that the EC2config service exists and starts in the Windows Services panel.

7. In a command line window, run "slmgr /ato". A pop-up window opens stating that Windows has been successfully activated, see Figure 3.

8. Verify that ArcGIS for Server runs correctly.

9. Optionally, an AMI can be created from this instance. New instances started from this AMI will all have the fixes applied.

Article ID:000011696

Software:
  • ArcGIS Server

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Discover more on this topic