ERROR

ArcLogistics error: Unable to open project. Locator not found

Last Published: April 25, 2020

Error Message

When installing data updates or moving projects to a new machine, the following ArcLogistics error is returned within the New Project wizard dialog box:

"Unable to open the project.
Locator not found."

Cause

The error may be related to data licensing, which is hidden by ArcLogistics. The first time the .mxd file for a new project is selected or created, ArcLogistics finds the street data license and registers it.

The error is likely a result of moving or renaming the location of a street dataset, which can break the .mxd file so that data layers no longer draw on the map.

Solution or Workaround

Street data or ArcLogistics project files can be moved, but the projects may need to be repaired manually.

An ArcLogistics project consists of the project.xml file, the project.mxd file, and the project.gdb folder (where 'project' is the name of the ArcLogistics project). It is best practice to keep these together if the project files are moved.

The project.xml file is where file paths and directory locations are stored. When everything is on the same drive/volume, ArcLogistics will use relative path names where possible.

To fix this issue, follow the steps below:

1. One way to fix this is to make a new project in ArcLogistics.

2. Point to the .mxd at the new data location.

3. Use the existing (broken) project as a template. From the template project, all of the data including Inbox Orders and existing routing folders can be copied across.


Note:
Moving projects and street data around in ArcLogistics between different drives on the same computer or among different computers does not need to be a difficult or taxing process.

The following are some tips to assist in this process:

• Keep the street dataset on the same drive or relative path as the projects. For example, store the street data at 'D:\ALRStreetData' and the projects at 'D:\ALRProjects'. Now these two folders can be moved anywhere: to a different folder level or to a different drive or computer. Since the paths are relative and the name of the street data folder has not been changed, relative path references within the project.xml file continue to work.

• If ArcLogistics street data is copied or reinstalled to another computer, name the folder the same on the other computer so that the projects continue to reference a valid drive letter and path.

The default path to the dataset will differ depending on the operating system:

▪ In Windows Vista, this is located at C:\ProgramData\ESRI\ArcLogistics\Streetdata\TANA<your data version>\MXD.

▪ In Windows XP, this is located at C:\Documents and Settings\All Users\Application Data\ESRI\ArcLogistics\StreetData\TANA<your data version>\MXD.

• Another tip is to browse to the StreetData\MXD folder in Windows Explorer and double-click the .sdlic file. This will reassociate ArcLogistics to the StreetMap data and register the data license.

Article ID:000010797

Software:
  • Legacy Products

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Discover more on this topic