PROBLEM

Results from Search, Query, and Identify are not being highlighted in the map

Last Published: April 25, 2020

Description

After running the Query, Search, or Identify tool, results are not being highlighted in the map.

In the case of the Query task, the results table is also missing check boxes next to each result and the Zoom To and Pan To context menu options are not available. For Search or Identify results, the check boxes are displayed but checking them on still does not highlight features in the map.

This issue applies to Web applications built with the ArcGIS Server Web ADF for the Microsoft .NET Framework.

Cause

The SHAPE field is not turned on for the layer in the source map document.

Solution or Workaround



  1. Using Manager or ArcCatalog, stop the map service that the Web application is using.
  2. Start ArcMap and open the source map document.
  3. Open the layer properties for the layer that the task is using.
  4. Click the Fields tab. There is a list of the fields in the layer.
  5. Make sure the check box next to the SHAPE field is checked on.
  6. Save the map document and restart the service.

Article ID:000010384

Software:
  • ArcGIS Server

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Discover more on this topic