PROBLEM

ArcGlobe stops responding at "Generating ArcID Module" and does not open

Last Published: December 1, 2020

Description

After installing ArcGIS Desktop, ArcGlobe sometimes stops responding at the "Generating ArcID Module" message. The Task Manager reveals that ArcGlobe.exe is running and is consuming processor time, but the application does not open.

Note:
This article pertains to ArcGIS Server versions 10.0 and prior only. Later versions of ArcGIS may contain different functionality, as well as different names and locations for menus, commands and geoprocessing tools.

Cause

On machines with multiple processor cores, one or more of the cores may be operating at maximum capacity, while the other is not. In these cases, if the processor workload is unable to be redistributed, ArcGlobe will not open completely. Ending the ArcGlobe.exe process does not cause the processor workload to automatically redistribute properly.

Warning:
The following instructions involve modifying critical components of your operating system. It is recommended that you backup your operating system and files, including the registry, before proceeding. Consult with a qualified computer systems professional, if necessary. ESRI cannot guarantee results from incorrect modifications while following these instructions; therefore, use caution and proceed at your own risk.

Solution or Workaround

To workaround this issue, follow the steps below to disable and then re-enable multi-processor support.

For Windows 2000, Windows XP, and Windows 2003:

  1. Edit the boot.ini file on the machine to disable multi-processor support.
  2. Right-click on My Computer, and select Properties.
  3. In the Properties window, click the Advanced tab.
  4. In the Startup and Recovery area, click the Settings button.
  5. Beside the label To edit the startup options file manually, click Edit, press Edit.
  6. In the Boot.ini file, add the option /numproc=1 after the option /fastdetect. Click File > Save. Close the Boot.ini file.
  7. Reboot the machine. After the machine reboots, open ArcGlobe. It should open without issues.
  8. After ArcGlobe is successfully opened, close the application. Follow steps 1-3 above, and remove the option /numproc=1 after the option /fastdetect and save the change.
  9. Reboot the machine again. ArcGlobe should now open and function correctly with no further issues.

In Windows Vista and Windows Server 2008, there is not a boot.ini file. Instead, the number of processors available at system startup may be defined in the Advanced Boot Options in the Windows System Configuration tool.

  1. From the Windows Desktop, press the Start button and select RUN.
  2. In the RUN box, type MSCONFIG and press [enter].
  3. The Windows System Configuration tool opens. In the System Configuration tool, select the Boot tab and click the Advanced Options button.
  4. In the Boot Advanced Options dialog box, check the box next to Number of Processors to activate the processor number drop-down menu, and select 1 as the number of processors available.
  5. Reboot the machine. ArcGlobe should now open and function correctly with no further issues.
  6. After ArcGlobe is successfully opened, close the application. Follow steps 8-10 from the previous section, but change the number of processors available back to the original value.
  7. Reboot the machine again. ArcGlobe should now open and function correctly with no further issues.

Article ID:000010286

Software:
  • ArcGIS Server

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