PROBLEM

Installation stops responding when registering .ocx files

Last Published: October 2, 2020

Description

The installation of ArcGIS Desktop stops responding or does not continue at the point of registering a .dll or a .ocx file. The .ocx file can differ depending on the specific machine on which ArcGIS is being installed.

Cause

The .ocx files are Active X controls that can sometimes be blocked by anti-virus software.

Solution or Workaround

If the ArcGIS Desktop installation stops responding at this point, disable any anti-virus software, and the installation should continue. If the install does not continue, follow the steps below.
  1. Open the Task Manager by pressing Ctrl + Alt + Delete at the same time and select Task Manager.
  2. Select the Processes tab and locate any and all processes named msiexec.exe.
  3. Find the msiexec.exe that is using the least amount of CPU percentage. Select it and click the End Process button at the bottom right corner. Continue to end the msiexec.exe processes that use the least amount of CPU until the ArcGIS installation continues.
[O-Image]
  1. Once the installation is complete, it is necessary to re-register the .ocx. This can be done by going to Start > Run. Type 'cmd' and select OK.
  2. Change the directory to c:\program files\arcgis\bin and type the following command: regsvr32, followed by the specific .ocx name, for instance regsvr32 teechart7.ocx
[O-Image]

Article ID:000009934

Software:
  • ArcMap

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Discover more on this topic