ERROR

Closed polylines are not allowed for network features

Last Published: September 17, 2021

Error Message

In one of the three scenarios below, the following error is returned:

Error:
Closed polylines are not allowed for network features.

Scenario 1: When using XML Import or the Extract Data and Create Replica commands on the Distributed Geodatabase toolbar, if the source features are geometric network features, the operation may fail and return the closed polyline error message.

Scenario 2: During conflict resolution on the Conflicts dialog box.

Scenario 3: During reconcile, in which the error message is appended to the end of a "The version failed to reconcile" error message. The error message may or may not be appended with information concerning the class name and Object ID of the feature causing the error.

Cause

  • Scenario 1: The operation fails because of the presence of closed polylines (polylines with the same start-stop vertex) within the source geometric network feature classes. These features are invalid within the geometric network. Therefore, they are flagged as build errors during network creation. Refer to ArcMap: Identifying geometric network build errors for more information.
  • Scenarios 2 or 3: The geometry for an edge element collapses on itself and forms a polyline or geometry with a length of zero or a geometry whose end points are snapping to one another. The geometry may correspond to an entire edge feature or to a segment of a complex edge feature.

Solution or Workaround

Depending on the cause, choose one of the options below to resolve the issue:

Scenario 1

Correct the geometry of the features in the source network feature class using the steps outlined in ArcMap: Repairing features with an identical start–stop vertex.

Scenario 2

Scenario 2 may be resolved if it is possible to identify which feature caused the error. This is done by resolving conflicts at a class or feature level. If the feature causing the error is identified, complete the instructions below:

  1. Use the Disconnect command on the feature prior to resolving the conflict.
  2. Determine if the feature has inconsistent connectivity, and use the Rebuild Connectivity tool on the feature.
  3. Assess whether the replacement is necessary, or if it can be done in the primary version following the post.

If this error is unresolved, contact Esri Technical Support to troubleshoot this issue.

Scenario 3

Scenario 3 may be resolved if it is possible to identify which feature caused the error. This is done by resolving conflicts at a class or feature level. If the feature causing the error is identified, use the Disconnect command on the feature prior to reconciling the version.

If this error is unresolved, contact Esri Technical Support to troubleshoot this issue.

Article ID:000009900

Software:
  • ArcMap 9 x
  • ArcMap 10 6
  • ArcMap 10 x
  • ArcMap 10 7
  • ArcMap 10 8

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