BUG

Portal search results "View Globe" button wipes out existing ArcGIS Explorer map layers

Last Published: April 25, 2020

Description

When selecting the 'View Globe' button in a search result for metadata describing a Live Service, ArcGIS Explorer launches, and adds the Live Service as a layer. However, all existing layers, including base layers, are removed.

Cause

The XSL stylesheet that generates the .nmf file from the Portal needs to be updated.

Workaround


Note:
The following fix can only be carried out by someone who has access to the Portal's servlet engine files. If the regular user of the portal does not have access to these files, please contact the portal's administrator and refer them to this fix.

  1. Download the 'GPT 3.1 Update to View Globe Functionality' patch from the GPT Support Site. A link is also provided in the Related Information section below.
  2. Navigate to the <TOMCAT>\webapps\Portal\xsl directory on the Web server that hosts the portal installation.
  3. Backup the existing ViewWith_nmf.xsl file by moving it to a different location or saving it with a different name (i.e. ViewWith_nmf.xsl.old).
  4. Copy the downloaded patch file (viewWith_nmf.xsl) into the same directory referred to in step 2.
  5. Refresh the Web browser and test the 'View Globe' function again.
  6. If there is no change in functionality after replacing the ViewWith_nmf.xsl file, restart Tomcat.

Article ID:000009809

Software:
  • Legacy Products

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic