PROBLEM

MXD file size increases significantly with subsequent saves

Last Published: April 25, 2020

Description

In some cases MXD file size may increase significantly. For example:
File size may be less than one megabyte before the first save, 6.5 megabytes on the first save, 13 megabytes on the second and subsequent saves.

Cause

The file size increase may be caused by a large amount of geoprocessing results stored in the Results tab in ArcToolbox in ArcCatalog.

Whenever a geoprocessing tool is run in ArcCatalog, the results are stored in the Results tab in ArcToolbox which persists between ArcCatalog sessions. Conversely, when a geoprocessing tool is run in ArcMap, the results are stored in the Results tab in ArcToolbox and saved within the MXD.

The ArcCatalog Results tab cause MXDs to increase size. When ArcMap starts up, it loads the contents of ArcCatalog's ArcToolbox Results tab into ArcMap's ArcToolbox Results tab. Moreover, if an MXD is loaded into ArcMap, it also loads the Results tab stored in the MXD. When the MXD is saved, the contents of the Results tab are written to the MXD which includes the contents of the Results tab from ArcCatalog. All of the contents written to the MXD can be an issue because it is common for the Results tab to contain many geoprocessing results, potentially spanning many months, which may cause MXD 'bloat'.

Note:
If many geoprocessing operations are performed, it is good practice to occasionally clear the Results tab in ArcToolbox in ArcMap and ArcCatalog on a regular basis. They are not cleared automatically by the application.

Solution or Workaround

The following steps permanently clear the Results tab in ArcToolbox. Previous geoprocessing results are available in the History toolbox, if needed. See the Related Information for more information on retrieving results from the the History toolbox.

  1. Shut down ArcMap and open ArcCatalog.
  2. Go to ArcToolbox > Results Tab. In the Results tab, look for 'Current Session' and 'Previous Sessions'. If 'Previous Sessions' is not there, go to to step 4. If 'Previous Sessions' is there, go to step 3.
  3. Right-click 'Previous Sessions' > Remove All.
  4. Open the problematic MXD in ArcMap.
  5. Click File > Save As. Save the MXD to a new name.
  6. Check to see if the problem has been resolved. If it has been resolved, do not continue with the rest of the steps. If the problem persists, go to step 7.
  7. Go to ArcToolbox > Results Tab. In the Results tab, look for 'Current Session' and 'Previous Sessions'. Right-click 'Previous Sessions' > Remove All.
  8. Click File > Save As. Save the MXD to a new name.

Article ID:000009451

Software:
  • ArcMap 9 x

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