PROBLEM

Please wait while Windows configures ArcGIS Desktop

Last Published: April 25, 2020

Description

When opening ArcMap or ArcCatalog, an ArcGIS Desktop dialog box displays the following message:

"Please wait while Windows configures ArcGIS Desktop"

The program continues to install ArcGIS Desktop and asks for the installation source if it cannot find it.

Cause

ArcMap or ArcCatalog is looking for a file or group of files that is no longer available. The removal of the file(s) may be caused by the installation of a new software, system update or anti-virus.

Solution or Workaround

Look in the System Event Viewer:

  1. Click Start > Control Panel > Administrative Tools > Event Viewer.
  2. Highlight the Application or Application Log in the Event Viewer.
  3. Double-click on the latest MisInstaller log. If it does not appear similar to the one shown below, click on the next one.
    The product, ArcCatalog, is searching for a specific file. In the following example the file RepairGIOApps.exe is missing.

    [O-Image] [O-image] Log from Event Viewer
  4. Search for the missing file from another workstation or through the Internet.
  5. Open the Windows Explorer and navigate to the specified directory shown in the Event Viewer. Copy and paste the missing file into the directory.

Article ID:000008636

Software:
  • ArcMap 8 x
  • ArcMap 9 x

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Discover more on this topic