ERROR

The final registration process did not complete successfully

Last Published: April 25, 2020

Error Message

ArcView or ArcEditor Single Use registration may fail on a machine that has ArcIMS 9.x and/or ArcGIS Server 9.x installed and running. Although the Desktop Administrator and the license directory indicate the registration process was successful, ArcMap and ArcCatalog will fail to start.

The following error may be reported at the end of the registration process:

"The final registration process did not complete successfully.

Make sure you are logged on as the same user
"yourname" who installed the software, then run
the registration wizard again and either browse
to your authorization file, or if you registered
using the automatic method, do that one again."

Cause

The Windows services that are running for ArcIMS and/or ArcGIS Server create a file lock that prevents the Single Use software from completely registering.

Solution or Workaround

Stop the according services, re-register the software, and start the services again:

  1. Stop ArcIMS:

    Summary:
    The ArcIMS Windows services must be stopped and started in a specific sequence.

    Use the following order when stopping services:
    a) ArcIMS Tasker
    b) ArcIMS Monitor
    c) ArcIMS Application Server

    The services should be started in the opposite order:
    a) ArcIMS Application Server
    b) ArcIMS Monitor
    c) ArcIMS Tasker

    Procedure:


    1. Open the Services console.

      · Windows NT: Click Start > Settings > Control Panel > Services

      · Windows 2000/2003: Click Start > Settings > Control Panel > Administrative Tools > Services

      · Windows XP: Click Start > Control Panel > Performance and Maintenance > Administrative Tools > Services


    2. Click the appropriate service name.
    3. Click the Stop or Start button, as appropriate.
    4. Repeat this process for each service in the sequence noted above.
    5. Close the Services console.


    Stop ArcGIS Server:

    A. Open the Services control panel.
    · Windows NT: Click Start > Settings > Control Panel > Services
    · Windows 2000/2003: Click Start > Settings > Control Panel > Administrative Tools > Services
    · Windows XP: Click Start > Control Panel > Performance and Maintenance > Administrative Tools > Services

    B. Find this service in the list:
    ArcGIS Server Object Manager

    C. Stop the service.

  2. Re-register ArcView or ArcEditor Single Use.
  3. Start ArcIMS:

    Summary:
    The ArcIMS Windows services must be stopped and started in a specific sequence.

    Use the following order when stopping services:
    a) ArcIMS Tasker
    b) ArcIMS Monitor
    c) ArcIMS Application Server

    The services should be started in the opposite order:
    a) ArcIMS Application Server
    b) ArcIMS Monitor
    c) ArcIMS Tasker

    Procedure:


    1. Open the Services console.

      · Windows NT: Click Start > Settings > Control Panel > Services

      · Windows 2000/2003: Click Start > Settings > Control Panel > Administrative Tools > Services

      · Windows XP: Click Start > Control Panel > Performance and Maintenance > Administrative Tools > Services


    2. Click the appropriate service name.
    3. Click the Stop or Start button, as appropriate.
    4. Repeat this process for each service in the sequence noted above.
    5. Close the Services console.


    Start ArcGIS Server:

    A. Open the Services control panel
    · Windows NT: Click Start > Settings > Control Panel > Services
    · Windows 2000/2003: Click Start > Settings > Control Panel > Administrative Tools > Services
    · Windows XP: Click Start > Control Panel > Performance and Maintenance > Administrative Tools > Services

    B. Find this service in the list:
    ArcGIS Server Object Manager

    C. Start the service.

Article ID:000007236

Software:
  • ArcMap 9 x

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