BUG

ArcIMS Z39.50 connector disables ArcIMS Java applications: Author, Administrator, Designer

Last Published: April 25, 2020

Description

While running the ArcIMS Z39.50 Connector, the ArcIMS Author, Designer, Manager and Administrator applications may fail to run properly or not start.

Cause

The logging window that appears when the ArcIMS Z39.50 Connector is started is using system resources in a way that causes other Java applications to fail.

Workaround

Disable the Java logging window in the log.properties file.

  1. Open the log.properties file in a text editor; for example, NotePad. Locate the file at: <ArcIMS Installation Folder>\Metadata\Z3950Connector
  2. Delete the reference to the JavaWindow logging appender by deleting "JavaWindow" from the second line of the file.

    Before modification:

    Code:
    # declare your logging appenders here
    log4j.rootLogger=DEBUG, stdout, JavaWindow, Access, Debug

    After modification:

    Code:
    # declare your logging appenders here
    log4j.rootLogger=DEBUG, stdout, Access, Debug

  3. Save and close the file.
  4. Stop and restart the ArcIMS Z3950 9.0 service.

    - When using Windows NT, select Start > Settings > Control Panel > Services

    - When using Windows 2000/XP/2003, select Start > Settings > Control Panel > Administrative Tools > Services

Article ID:000007048

Software:
  • Legacy Products

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