PROBLEM

Output image generates with missing blocks of information on export

Last Published: April 26, 2020

Description

** This issue has been resolved in ArcIMS 9.0.1. **

When exporting a large image or layout, the output image is generated with missing blocks of information.

Cause

This is a known limit with ArcMap Sever on Solaris in ArcIMS 9.0.

Solution or Workaround

Increase the memory limit for buffer allocation used with raster exports. Increase the value of this registry key:
HKCU\software\esri\output\ESRIExportRasterBufferSizeMB

The steps below describe modifying the value of this setting in the registry:
  1. Open a new terminal on the machine where ArcMap server is installed.
  2. Source $AIMSHOME/../init_engine.csh
  3. Type 'regedit'. This opens the Registry Editor window.
    Warning:
    The instructions below include making changes to essential parts of your operating system. It is recommended that you backup your operating system and files, including the registry, before proceeding. Consult with a qualified computer systems professional, if necessary.
    
    Esri cannot guarantee results from incorrect modifications while following these instructions; therefore, use caution and proceed at your own risk.
  4. Navigate to HKEY_CURRENT_USER\software\esri and create a new key 'output' in the Registry Editor window.
  5. Create a new 'DWORD Value' under the output key and rename it as 'ESRIExportRasterBufferSizeMB'.
  6. Set the value of 'ESRIExportRasterBufferSizeMB' to 16 Hexadecimal. Increase the values for larger exports.
  7. Exit the Registry Editor.
  8. Navigate to $AIMSHOME/qs_scripts directory and run the stop_arcims script to stop all the ArcIMS services.
  9. After the ArcIMS Services have stopped, stop MainWin runtime by typing 'mwadm stop'.
  10. Start MainWin runtime by typing 'mwadm start'.
  11. At a new terminal navigate to $AIMSHOME/qs_scripts directory and run 'start_arcims' script. This starts all ArcIMS Services.

Article ID:000006725

Software:
  • Legacy Products

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