PROBLEM

HTTP 500 Error when opening ArcIMS Service Administrator in a browser

Last Published: April 25, 2020

Description

When attempting to open ArcIMS Service Administrator in a browser such as Internet Explorer, a blue page briefly appears and is immediately followed by a "Page Cannot be Displayed, Error 500" page.

This is known to occur only for ArcIMS configurations using IIS and Servlet Exec.

Cause

An HTTP Error 500 is an Internal Server Error which indicates that the Web server is incapable of performing the request sent by an ArcIMS client. There are a number of possible causes to this problem as they relate to Service Administrator. The following list may not show all causes of a HTTP 500 Error, however the most probable causes are listed first.

  • Inadequate NTFS permissions on Servlet Exec ISAPI installation directory and sub-directories.
  • The Java connector is not installed.
  • Reference to Java connector installation location for Servlet Exec is not specified.
  • A supported version of Java Developer Kit (JDK) is not installed.

Solution or Workaround

This document assumes that the user has already followed the instructions outlined in Step 3 (or 3a for ArcIMS 4.0.1) in the ArcIMS Installation Guide for installing the ArcIMS Service Administrator.
  1. Inadequate NTFS permissions for Servlet Exec installation directory.
  1. Set 'Full Control' permissions on the Servlet Exec ISAPI directory and all subdirectories for the following users and groups.
  • SYSTEM (group)
  • Authenticated Users (group)
  • IUSR_<servername> (user)
Note:
Consult the Servlet Exec Installation guide for required permissions.
  1. Open Internet Services Manager for IIS.
  2. Right-click the 'Scripts' virtual directory and select 'Properties'.
  3. Set the Execute Permissions field to 'Scripts and Executables'. Click OK.
  1. The Java Connector is not installed. The ArcIMS Service Administrator uses the Java connector to communicate with the Application Server. To install the Java connector, see the directions below or consult the ArcIMS Installation Guide.
  1. Run the Setup program from the ArcIMS installation CD.
  • For ArcIMS 4.0:
  1. Select the 'Custom' installation option.
  2. Uncheck all options except for 'Application Server Connectors'.
  3. Click 'Application Server Connectors'.
  4. Click 'Custom'.
  5. Check the box beside the 'Java Connector' option.
  6. Complete the installation setup program.
  • For ArcIMS 4.0.1:
  1. Select the 'Add/Remove' installation option.
  2. Expand the 'Application Server Connectors' option.
  3. For the Java Connector, select the 'Will be installed on local hard drive' option.
  4. Complete the installation setup program.
  1. Ensure that the 'arcims_jconnect.jar' file has been installed in <ArcIMS Installation Directory>\Connectors\Java_Connector.
  1. Reference to the Java connector installation location for Servlet Exec is not specified.
  1. Open the Servlet Exec Administration page by typing in the following in a web browser:
http://<machinename>/servlet/admin
  1. Under 'Virtual Machine', click 'classpath'.
  2. Type the following in the empty field:
<drive>:\Program Files\ArcGIS\ArcIMS\Connectors\Java_Connector\arcims_jconnect.jar
Note:
Alter the installation path to reflect your environment.
  1. Click 'Submit'.
  1. A supported version of JDK is not installed. Service Administrator is a series of jsp pages that need to be compiled at runtime. This can only be done with the Java Developer Kit (JDK) and not the Java Runtime Environment (JRE) only.
Note:
The following steps outline the procedure to install JDK 1.3.1_02 on your system. This specific version is supported for ArcIMS 4.0 and 4.0.1.

Please check the ArcIMS System Requirements Page for all currently supported versions of the JDK with ArcIMS.
  1. Click the Download Sun Java 2 SDK, Standard Edition, version 1.3.1_02 link in the Related Information section below.
  2. Choose Continue next to the 'Windows 95/98/2000/NT 4.0' option.
  3. After accepting the license agreement, click 'Download j2sdk-1_3_1_02-win.exe'.
  4. Run the program after it has finished downloading.
  5. Accept all the default installation locations unless there is sufficient reason to change them.
Set environment variables:
  1. Navigate to your Environment Variables.
  2. Under System Variables, click 'New'. For Variable Name, type JAVA_HOME. The variable name is case sensitive. For Variable value, type the path where you installed the Java 2 SDK; for example <drive>:\jdk1.3.1_02, and click OK.
  3. While in the System Variables panel, scroll down to 'Path', select it and click 'Edit'. In the Variable Value text box, append the following to the end of the text, including the semi-colon:
;%JAVA_HOME%\bin
Note:
Make sure you do not have old references to JAVA_HOME; for example, <drive:>\jdk1.2, in the Path variable.

Article ID:000006277

Software:
  • Legacy Products

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