English

FAQ: Why doesn't the OLEDB-compliant provider work with ArcGIS?

Question

Why doesn't the OLEDB-compliant provider work with ArcGIS?

Answer

Additional standard interfaces are required beyond the minimum required for OLEDB compliance. Go to ArcObjects Online > Technical Documents > "Implementing OLE DB Providers" to see the list of the interfaces that are required.

View the interfaces supported by a provider by using the Microsoft Rowset viewer. Search the Microsoft Web site to find the viewer.

Last Published: 5/5/2016

Article ID: 000006100

Software: ArcGIS-ArcEditor 9.1, 9.0, 8.3, 8.2, 8.1.2, 8.1 ArcGIS-ArcInfo 9.1, 9.0, 8.3, 8.2, 8.1.2, 8.1, 8.0.2, 8.0.1 ArcGIS-ArcView 9.1, 8.3, 8.2, 8.1.2, 8.1