ERROR

HTTP error 404" when clicking the View Map button in Metadata Explorer

Last Published: April 25, 2020

Error Message

When clicking the View Map button in Metadata Explorer, the following error message may occur:

"HTTP Error 404: Not Found"

Cause

One of the Metadata Explorer files references a URL that exceeds the limits for parameters passed in a URL.

Solution or Workaround

The following procedure resolves the issue at ArcIMS 4.0.x. This resolution has also been incorporated into ArcIMS for the next release.

  1. Locate the Metadata Explorer's map_view.htm file. This file will be found in the <<servlet engine>>\metadataexplorer folder.
  2. Rename the map_view.htm file to map_loading.jsp.
  3. Find the content_frames.jsp file located in the same \metadataexplorer folder.
  4. Open content_frames.jsp in a text editor, such as Notepad.
  5. Find all occurences of 'map_view.htm' and replace them with 'map_loading.jsp'. The quotation marks are for clarity, and should be ignored when actually performing this step.
  6. Save and close the content_frames.jsp file.
  7. Stop the ArcIMS services in this order: Tasker, Monitor, AppServer.
    <a href='http://support.esri.com/en/knowledgebase/techarticles/detail/23705' target='_blank'>[O] - Stop and Start ArcIMS Windows services</a>
  8. Stop and restart the Web server service(s).
  9. Restart the ArcIMS services in this order: AppServer, Monitor, Tasker.
    <a href='http://support.esri.com/en/knowledgebase/techarticles/detail/23705' target='_blank'>[O] - Stop and Start ArcIMS Windows services</a>

Article ID:000005826

Software:
  • Legacy Products

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic