PROBLEM

Creating metadata for ArcIMS services: Metadata does not save

Last Published: April 25, 2020

Description

In ArcCatalog, Metadata created for ArcIMS services fails to save even though a valid "metadata_service_author" user name and password was used to successfully connect to the ArcIMS server, the Edit Metadata button is enabled, and information can be entered into the Metadata fields.

Note: The Metadata Service is listed in ArcCatalog using the publish icon (hand holding a pen) if an appropriate user name and password were used to connect to the ArcIMS server.

Cause

The Metadata Service and the ArcIMS services you wish to create metadata for are not specifically listed in the the "metadata_service_author" role of the Access Control List (ACL). The symbol *, indicating all services, cannot be used in defining the "metadata_service_author" role.

Solution or Workaround

The Metadata Service, and any other ArcIMS services you want to create metadata for, must be specified by name in the </USER> parameter associated with the "metadata_service_author" role.

Edit your ArcIMS ACL to include the Metadata Service and any other ArcIMS services you would like to create metadata for within the "metadata_service_author" role.

The following example shows how to set up a <USER/> element in the ACL file for the "metadata_service_author" role. In this example, the Metadata Service is called "Metadata" and metadata can be created and published for two ArcIMS services: "mexico" and "sanfrancisco."

Code:
</USER name="author" password="author" roles="metadata_service_author"
services="Metadata,mexico,sanfrancisco" active="1" />

For further information on restricting access to services using Access Control Lists (ACL) and metadata-related roles, see ArcIMS Help or "Creating and Using Metadata Services".

Article ID:000005573

Software:
  • ArcMap 8 x
  • Legacy Products

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Discover more on this topic