Description
Geocoding against a coverage in ArcGIS results in zero matches, whereas the same geocoding procedure produces expected results in ArcView 3.x.
Cause
The coverage's geocoding index file (.aig) is corrupt.
Solution or Workaround
Delete the coverage's geocoding index file and rebuild the geocoding service.
- Make a backup copy of the coverage.
A. Start ArcCatalog.
B. Browse to the coverage workspace.
C. Right-click on the coverage > Copy.
E. Browse to the folder where the coverage will be copied.
F. Right-click on the folder > Paste.
- Start Windows Explorer.
- Navigate to the coverage workspace directory.
- Open the coverage folder.
- Delete the index file.
- Close Windows Explorer.
- Rebuild the geocoding service in ArcCatalog.
You can find information regarding creating geocoding services in the ArcGIS Help Topics under Geocoding addresses > Managing geocoding services in ArcCatalog.