PROBLEM

Errors when trying to connect to a database

Last Published: April 25, 2020

Description

Occasionally errors can arise when trying to connect to a database on an AS/400 using a HIT Technologies driver.

Cause

This is due to an incompatibility with the winsock32.dll in the Arcview startup script.

Solution or Workaround

Use HIT ODBC drivers with SQL connect

  1. Start Windows Explorer.
  2. Navigate to where Arcview is installed.
  3. Open the Startup file in the AV_GIS30/Arcview/ETC directory in a text editor such as Notepad or WordPad.
  4. Find the following lines:

    Code:
    if (FN.FindInSystemSearchPath("wsock32.dll) <> nil) then
    System.LoadLibrary("$AVBIN/avrpc.dll".AsFileName)
    end


  5. Comment out those lines by inserting a single quotation mark at the beginning of each line.
  6. Save the file as Startup.

    Note:
    Use Windows Explorer to make sure the text editor did not add a .txt extension to the file.

  7. Restart your computer.
  8. Retry the SQL connection.

Article ID:000004100

Software:
  • Legacy Products

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