PROBLEM

When I overwrite an existing shapefile with an older version, ArcIMS does not update the index files

Last Published: April 25, 2020

Description

When I overwrite an existing shapefile with an older version, ArcIMS does not update the index files.

Cause

In ArcIMS, index files are:

1. Created if a shapefile does not have the corresponding index files.

2. Updated if the new shapefile has a date and time stamp that is younger than the index files.

Solution or Workaround

When an existing shapefile is overwritten with an older shapefile, neither of the above conditions apply. To synchronize the index files with the older shapefile do one of the following:

  • Delete the existing index files and ArcIMS will automatically reindex the shapefile.
  • Update the existing index files by copying in the older index files.

Article ID:000003421

Software:
  • Legacy Products

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Discover more on this topic