PROBLEM

Tables are not listed in the SQL dialog after connecting to a SQL Server database

Last Published: April 25, 2020

Description

After connecting to a SQL Server database, using SQL Connect, there are no tables listed in the SQL dialog box and the Connect button is disabled.

Cause

Table Ownership.

In most cases when you connect to a SQL Server database, using SQL Connect, you will be prompted for a username and password for access to the database. The username and password are then passed to the SQL Server database to verify your account. The database is then queried based on the user logged in as the owner of tables. If the user does not own any tables, ArcView will not list any tables in the SQL dialog.

Solution or Workaround

Try one of these two solutions:

  • In order to see a list of the tables in the SQL Server database, type the owner name in the owner field of the SQL dialog box and hit the enter key on your keyboard. This will list the tables owned by that user.

    Note:
    You may want to contact your database administrator to find the owner names of the tables you are interested in.

  • Type a % in the owner field and hit the enter key on your keyboard. The % acts as a wild card. All of the tables in the SQL Server database will be listed.

Article ID:000002749

Software:
  • Legacy Products

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