PROBLEM

Requests take a long time to process and timeout

Last Published: April 25, 2020

Description

If you have very complicated maps, it may be necessary to optimize the performance of ArcIMS by updating the AppServer.properties file.

Cause

The AppServer.properties file contains the defaults for the ArcIMS Application Server. The Timeout properties default is 60 seconds and the ExtendedTimeout properties default is 300 seconds.

It is recommended that these defaults not be changed; however in custom sites, changes to these properties may be necessary. For example, you may need to increase the Timeout property so that the Application Server will not give up on the request if the map is not transmitted within the default of 60 seconds.

Solution or Workaround



You can change the values of the Timeout and ExtendedTimeout properties in the AppServer.properties file.

On Windows:
The AppServer.properties file is located at <ArcIMS Installation Directory>\AppServer.

On Solaris and Linux:
The file is located at: $AIMSHOME/Middleware/Application_Server.

Timeout=60

The time period that the Application Server waits on an ArcIMS Spatial Server to respond to a client request. The stopwatch for this period starts as soon as the ArcIMS Spatial Server is sent the request from the Application Server. If the ArcIMS Spatial Server doesn't respond before this period ends, the Application Server gives up on the request and returns a timeout error to the client.

This figure should be tuned to synchronize with the maximum response time for service requests. The value is in seconds.

ExtendedTimeout=300

The time period that the Application Server waits on an ArcIMS Spatial Server to respond to an ADD/CHANGE SERVICE request by Administrator. The stopwatch for this period starts as soon as the ArcIMS Spatial Server is sent the request to add a service from the Application Server. If the ArcIMS Spatial Server doesn't respond before this period ends, the Application Server gives up on the ADD/CHANGE SERVICE request and returns a "failed to add/change service" error to the Administrator client.

This figure should be tuned to synchronize with the maximum time that the ArcIMS Spatial Server requires to get itself set up with the data sources and related tasks in setting up a new service. The value is in seconds.

Article ID:000002168

Software:
  • Legacy Products

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