ERROR

licserver not a valid server hostname

Last Published: September 19, 2022

Error Message

Note:
This article applies to retired ArcGIS products ArcInfo Workstation. Later versions of ArcGIS may contain different functionality, as well as different names and locations for menus, commands and geoprocessing tools.

This error appears in the license manager debug log file after ArcInfo fails to start:

"(lmgrd) licserver not a valid server hostname, exiting
(lmgrd) Valid server hosts are: hostname"

Cause

The machine's hostname doesn't match the hostname in the license files. It is also possible that TCP/IP is not installed properly.

Solution or Workaround

Check the hostname of the workstation.
  1. Click Start > Programs > Command Prompt. Type hostname to return the hostname of the computer.
  2. The hostname returned in Step 1 must match the hostname in the license files. If the hostname in the license file is different, change it to match the hostname of the workstation. The ArcGIS License Manager requires that the license file information be appropriate for the system and that it matches the information sent from the ESRI Keycode Department.
    SERVER server1 ESRI_SENTINEL_KEY=37123456 27005
    VENDOR ESRI
    FEATURE ARC/INFO ESRI 8.01 01-jan-00 1 3BFE602241F669DB9349 \
    		vendor_info="8DCZFL5B5R6D6RH8L023" ck=15
    1. The license files for ArcGIS are located in C:\Program Files\ESRI\License and end with a '.lic' file extension. The Arcinfo.lic file looks similar to this:
    2. The second entry on the SERVER line is the hostname of your computer. Make sure the hostname entry matches the actual hostname of the system (see step 1). The hostname entry is not tied to your keycode, and may be changed as long as it matches the hostname of the system that runs the license manager.
    3. The third entry on the SERVER line is the Sentinel Key number. This number should match the number returned by running Start > Programs > ArcGIS > License Manager > Display Hardware Key Status. Occasionally, the number printed on the Sentinel Key does not match the number returned by checking 'Display Hardware Key Status'. In this case, use the number returned by 'Display Hardware Key Status' to request new licenses.
      Notice this number always starts with a '3'. For example, if the e-mail tool used is Microsoft Outlook with Microsoft Word as the e-mail editor, all instances of '=3' will be stripped from the license file(s), as '=3' is a special Microsoft Word programming code. In such case, edit the license file(s) to restore the '=3'.
    4. The last item on each FEATURE line is the checksum number. The checksum number can also be stripped of a '=3'. The entry should contain 'ck=' followed by a number. If the equal sign is missing, the number three will also be missing. In such case, edit the license file(s) to restore the '=3' in the checksum number.
  3. Check to see if TCP/IP protocols are functioning.
Note:
The ArcGIS License Manager requires the installation of TCP/IP and a network card.
  1. Click Start > Programs > Accessories > Command Prompt. Type hostname to return the name of the system:
c:\> hostname
server1

In this example, the hostname is 'server1'. If the hostname command returns anything other than the machine's hostname, the TCP/IP may need to be installed or reinstalled. Contact a Network Administrator for assistance.

  1. Type ipconfig to return the IP address of the system.
c:\> ipconfig

Windows NT IP Configuration

Ethernet adapter El90x1:

		IP Address . . . . . . . : 198.102.62.22
		Subnet Mask. . . . . . . : 255.255.255.0
		Default Gateway. . . . . : 198.102.62.25
  1. Look at the 'IP Address' line for the current IP address of the computer.
  2. Ping the hostname as returned in Step a.
c:\> ping server1

Pinging server1 [198.102.62.22] with 32 bytes of data:

Reply from 198.102.62.22: bytes=32 time<10ms TTL=128
Reply from 198.102.62.22: bytes=32 time<10ms TTL=128
Reply from 198.102.62.22: bytes=32 time<10ms TTL=128
Reply from 198.102.62.22: bytes=32 time<10ms TTL=128
  • If the IP address returned by Step b matches the IP Address returned by the ping command, the local TCP/IP name resolution is set up and functioning properly.
  • If the IP address returned by Step b does not match the IP Address returned by the ping command, then name resolution for the system's hostname is incorrect. Contact a Network Administrator to correct the problem.
  1. If ArcGIS is attempting to check out licenses from a remote license manager, execute the ipconfig and ping commands on both the server and the workstation. In this example, the hostnames are workstation1 and server1.
  2. Run these commands while on the workstation:
c:\> ipconfig
c:\> ping workstation1
c:\> ping server1
  1. Run these commands while on the license server:
c:\> ipconfig
c:\> ping server1
c:\> ping workstation1

The IP address for the workstation should be identical when ping is performed on the workstation and the server. This is also true for the server. If a command returns a different IP address for a particular machine, TCP/IP is not functioning properly. Contact a System Administrator.

Article ID:000001950

Software:
  • ArcMap 8 x
  • Legacy Products

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