PROBLEM

3D Analyst Errors

Last Published: April 25, 2020

Description

After installing 3D Analyst, why do I get an error when I attempt to turn on the extension? Or, why do I get an error when I attempt to open a 3D scene and/or add data to a 3D scene?

Cause

System configuration.

Solution or Workaround




Warning:
WARNING: The instructions below include making changes to essential parts of your operating system. It is recommended that you backup your operating system and files, including the registry, before proceeding. Consult with a qualified computer systems professional, if necessary.

ESRI cannot guarantee results from incorrect modifications while following these instructions. Therefore, use caution and proceed at your own risk.


The following is a discussion and resolution for some common 3D Analyst installation errors and issues:

Arcview 3D Analyst uses OpenGL to render data in 3D. Configuration of OpenGL on a system consists of three components:

1) Software: Arcview with 3D Analyst
2) Software Solution: OpenGL libraries
3) Hardware Solution: Video Card and drivers

A problem with any of the above components will likely result in an unsuccessful implementation of the software utilizing OpenGL.

Windows Errors:

* AVTIN.dll failed to load...

Usually occurs when attempting to turn the extension on. This is usually the result of:

1) OpenGl software library incompatibility

OpenGL libraries are located in the windows/system directory and are called opengl32.dll and glu32.dll. They need to be present and a compatible version. Win95/98 platforms may have a number of versions to try, check Microsoft, the computer manufacturer, or the video card vendor for the most recent versions. This is usually not an issue with WinNT platforms (sizes should be in the range of Opengl32.dll: 684KB, Glu32.dll: 128KB).

2) Video card drivers need to be updated

Check the video card vendor site for updated drivers and/or OpenGL updated drivers.

3) Video card drivers need to have OpenGL enabled.

Some video cards come with software that allows you to configure the card and driver. This is usually added to the display properties window. Make sure that z-buffering is enabled.

* Invalid page fault or floating point exception when adding data to a 3D scene or opening a 3D scene

1) Display properties

Change the color palette settings first. Video cards differ when dealing with OpenGL rendering and color palettes, try the higher settings first then try the lowest settings. If this does not have an effect, set the color palette to 256 and change the resolution. Try both 1024x768 and 800x600.

2) Video card drivers need to be updated

Even if the first suggestion works, the resulting 3d scene display may be unsatisfactory. Check the video card vendor site for updated drivers and/or OpenGL updated drivers.

3) Spatial Analyst and 3d Analyst incompatability

If both Spatial Analyst and 3D Analyst have been installed, uninstall Spatial Analyst and 3D Analyst. Reinstall 3D Analyst and make sure it will function without Spatial Analyst. Note that only a CD containing the full version of Spatial Analyst 1.1 will allow both extensions to function properly. The Spatial Analyst 1.0/1.0a to 1.1 upgrade CD will continue to cause this error. Call your ESRI distributor or the ESRI Desktop order center to request a full version of Spatial Analyst 1.1.

UNIX Errors:

* AVTIN.dll failed to load...

1) The OpenGL libraries have not been loaded on the server (the machine where Arcview is installed).

The platform vendor should provide the OpenGL libraries for installation and setup. For example, SUN Solaris libraries and information are located at:

http://wwwwseast2.usec.sun.com/software/graphics/OpenGL/index.html

Often the libraries come with sample software to test whether they are loaded correctly or not. Use this to troubleshoot and confirm that the OpenGL libraries have been set up correctly. Also note that the OpenGL extension must be functioning for the libraries to be utilized. You can check this by typing "dpyinfo" at the command prompt to return display information. The "Extensions" parameter in the display information will inform you of the OpenGL status (for example, on the Solaris platform, look for the GLX extension to be active). Remeber that the machine where the OpenGL libraries were installed needs to be rebooted after installing thel libraries.

2) The OpenGL libraries need to be in the library path.

Make sure the LD_LIBRARY_PATH variable points to the location where the OpenGL libraries were installed.

3) Make sure you have an OpenGL compatible video card.

Some card are only compatible with other 3D rendering languages (such as PEX). Check the video card vendor site for more information.

* Unable to obtain OpenGL resources...

1) This error indicates that the OpenGL libraries have not been installed or cannot be accessed by the client machine where Arcview is running (being displayed).

Use the same methods as outlined in the "AVTIN.dll failed to load..." error information except apply it to the client machine. The OpenGL libraries should be installed on both the server and client machines. Some users have attempted to install the libraries in one location and point both machines to that location. They have experienced varying degrees of success- note that it is recommended to have the libraries installed on both the server and client.

Note that the color scheme for a 3D scene on a UNIX platform requires a 24-bit graphics card for accurate color representation.

Article ID:000001792

Software:
  • Legacy Products

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