ERROR

Cannot add user to subscription. Items and Groups cannot be moved into this type of subscription

Last Published: April 26, 2020

Error Message

When creating an ArcGIS Online for Organizations subscription, an Activation link is received through email. After browsing to this link, it is possible to activate the Organizational subscription using the login credentials from an existing Public account. When attempting to activate an ArcGIS Online for Organization subscription using an existing Public account, the following error message may be returned:

                                 User-added image
 

Cause

This error occurs when attempting to activate an Organizational account using an existing Public account that contains items in the My Content tab and/or groups in the Groups tab.

 

 

Solution or Workaround

The Organizational account can be activated or joined with an existing Public account using one of the following options:
  • To activate the Organizational subscription with an existing Public account, delete all items from the My Content tab and remove all groups from the Groups tab prior to logging in from the Activation link. Items can be deleted from the My Content tab or from the Item Details Settings tab. Groups can be removed from the account by going to the Groups tab and clicking the red icon to 'Delete Group' or 'Leave Group'.  
  • Although it is not possible to activate the Organizational subscription using a Public account that contains content, it is possible to join an Organization that has already been activated and maintain the content from the Public account. Use the following steps as a workaround to maintain the Public account content.
Note: This option can only be used when working with an Organizational subscription that allows for at least 2 members. 
  1. Activate the Organizational subscription by creating a new username.
  2. From the My Organization tab, Invite Members and use the option for Send invitations for existing users.
  3. Click the Invitation link that is received through email and sign in using the existing Public account. You will receive a warning that content will be transferred to the Organizational Account and the username will be added as a member of the Organizational account.
  4. Log in to the Organizational account using the username and password created in step 1.
  5. Go to the My Organization tab and Change the member role of the username that was added from the Public account to Administrator.
  6. Log in to the Organizational account using the username that was added from the Public account.
  7. From the My Organization tab, Delete the member that was used to Activate the subscription, so that only the desired username which includes content remains as an Organizational member.
Note: If the setting for Esri Access is enabled on the member when using Delete Member, the member's account will be converted to a Public account rather than the username being fully deleted from ArcGIS Online. 

 

Article ID:000001231

Software:
  • ArcGIS Online

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