English

Insights for ArcGIS 2.3 Custom Spatial Reference Patch

Summary

Without this patch, Insights will return an error when using layers with a custom spatial reference from Portal for ArcGIS' hosted data store. This is, therefore, a required patch for Insights for ArcGIS users using data with custom spatial references. This patch must be applied to each Server for ArcGIS machine with Insights for ArcGIS installed.

Description

Esri® announces the Insights for ArcGIS 2.3 Custom Spatial Reference Patch. Without this patch, Insights will return an error when using layers with a custom spatial reference from Portal for ArcGIS' hosted data store. This is, therefore, a required patch for Insights for ArcGIS users using data with custom spatial references. This patch must be applied to each Server for ArcGIS machine with Insights for ArcGIS installed. It deals specifically with the issue listed below under Issues Addressed with this patch.


In order for most workflows to be completely supported, two additional patches must also be installed:


Issues Addressed with this patch


  • BUG-000109295 - The Spatial Aggregation in Insights for ArcGIS fails if the inputs are a table geocoded into SVY21 using "Enable Location" and a hosted feature layer.
  • BUG-000109293 - The Spatial Aggregation tool in Insights for ArcGIS fails when run on two hosted feature layers if one is in a custom projection and the other is not.
  • BUG-000109290 - Calculate Density in Insights for ArcGIS fails on a hosted feature layer with a custom projection with the message, "Something went wrong."

Installing this patch on Windows


Installation Steps:


Insights for ArcGIS 2.3 must be installed before installing this patch.

  1. Download the appropriate file to a location other than your ArcGIS installation location.

  2. Insights for ArcGIS   Checksum (Md5)
         
    2.3 ArcGIS-230-IFA-CSR-Patch.msp 4CD932F163F801FF802C8FC06412C47D
         

  3. Make sure you have write access to your ArcGIS installation location.

  4. Double-click ArcGIS-230-IFA-CSR-Patch.msp to start the setup process.

    NOTE: If double clicking on the MSP file does not start the setup installation, you can start the setup installation manually by using the following command:

    msiexec.exe /p [location of Patch]\ArcGIS-230-IFA-CSR-Patch.msp


Installing this patch on Linux


Installation Steps:


Complete the following install steps as the ArcGIS Install owner. The Install owner is the owner of the arcgis folder.

Insights for ArcGIS 2.3 must be installed before installing this patch.

  1. Download the appropriate file to a location other than your ArcGIS installation location.


    Insights for ArcGIS   Checksum (Md5)
         
    2.3 ArcGIS-230-IFA-CSR-Patch-linux.tar FF5037E45E3D210FCC4EA30978ED8FFE
         

  2. Make sure you have write access to your ArcGIS installation location, and that no one is using ArcGIS.

  3. Extract the specified tar file by typing:

    % tar -xvf ArcGIS-230-IFA-CSR-Patch-linux.tar

  4. Start the installation by typing:

    % ./applypatch

    This will start the dialog for the menu-driven installation procedure. Default selections are noted in parentheses ( ). To quit the installation procedure, type 'q' at any time.

Uninstalling this patch on Windows


    To uninstall this patch on Windows, open the Windows Control Panel and navigate to installed programs. Make sure that "View installed updates" (upper left side of the Programs and Features dialog) is active. Select the patch name from the programs list and click Uninstall to remove the patch.

Uninstalling this patch on Linux


    To remove this patch, navigate to the /tmp directory and run the following script as the ArcGIS Install owner:

    ./patchremove

    Notes: You can only remove the patch that was installed most recently.

Patch Updates

Check the Patches and Service Packs page periodically for the availability of additional patches. New information about this patch will be posted here.

Getting Help

Domestic sites, please contact Esri Technical Support at 1-888-377-4575, if you have any difficulty installing this patch. International sites, please contact your local Esri software distributor.