English

ArcGIS 10.2.1 for (Desktop, Engine, Server) Support for Oracle 12.2 Patch

Summary

This patch enables Oracle 12.2 Geodatabases for ArcGIS Desktop / Engine / Server 10.2.1 clients.

Description

Esri® announces the ArcGIS 10.2.1 for (Desktop, Engine, Server) Support for Oracle 12.2 Patch. This patch addresses the need of Utility customers to leverage the latest database technology with their current ArcGIS software configurations. This patch deals specifically with the issues listed below under Issues Addressed with this Patch.


Note: ArcGIS clients connecting to an Oracle 12.2.0.1 database must use Oracle 11.2.0.4 or newer client.

Note: This patch is supported on version 10.2.1 and all versions of the Utility and Telecom update patches, the upgrade behavior will differ depending on your environment:

  1. This patch will not prompt for a geodatabase upgrade, if the geodatabase has already been upgraded with the ArcGIS 10.2.1 for (Desktop, Engine, Server) Utilities and Telecom Update 8 Patch.
  2. This patch will prompt for a geodatabase upgrade when installed on any earlier 10.2.1 patch. The upgrade is NOT mandatory to support Oracle 12.2.0.1. If upgraded, the geodatabase will be on par with ArcGIS 10.2.1 for (Desktop, Engine, Server) Utilities and Telecom Update 8 Patch.

Issues Addressed with this patch


  • BUG-000102310 - ORA-28578: protocol error during callback from an external procedure when querying the GDB_ITEMS_VW from an Oracle 12c sqlplus.

Installing this patch on Windows


Installation Notes:

System Administrators: A technical paper is available that discusses the enterprise deployment of ArcGIS 10.2.1 setups using Microsoft Systems Management Server (SMS), System Center Configuration Manager (SCCM), and Group Policy, including additional system requirements, suggestions, known issues, and Microsoft Software Installation (MSI) command line parameters. Deployment in a lockdown environment is also covered. ArcGIS 10.2.1 Enterprise Deployment.

Installation Steps:


ArcGIS 10.2.1 for Desktop, Engine, or Server must be installed before installing this patch.

  1. Download the appropriate file to a location other than your ArcGIS installation location.

  2.     Checksum (Md5)
         
    ArcGIS Desktop ArcGIS-1021-DT-SO12-Patch.msp 121314FAA2DAB058CF2320ABAAC17207
         
    ArcGIS Desktop
    Background Geoprocessing (64-bit)
    ArcGIS-1021-BGDT-SO12-Patch.msp C75706BE8A53E7FB32962C0E35475EC1
         
    ArcGIS Engine ArcGIS-1021-E-SO12-Patch.msp B5D6312BA39CCA72BE7336166FA2F845
         
    ArcGIS Engine
    Background Geoprocessing (64-bit)
    ArcGIS-1021-BGE-SO12-Patch.msp 3C369905F3674161BC8F178FD465886D
         
    ArcGIS for Server ArcGIS-1021-S-SO12-Patch.msp E35FF87BC1167F82EEE96555894F4508
         

  3. Make sure you have write access to your ArcGIS installation location.

  4. Double-click ArcGIS-1021-<product>-SO12-Patch.msp to start the setup process.

    NOTE: If double clicking on the MSP file does not start the setup installation, you can start the setup installation manually by using the following command:

    msiexec.exe /p [location of Patch]\ArcGIS-1021-<product>-SO12-Patch.msp

  5. After the installation procedure has finished, complete the Upgrade a geodatabase section.

Installing this patch on Linux


Installation Steps:


Complete the following install steps as the ArcGIS Install owner. The Install owner is the owner of the arcgis folder.

ArcGIS 10.2.1 for Engine or Server must be installed before installing this patch.

  1. Download the appropriate file to a location other than your ArcGIS installation location.


        Checksum (Md5)
         
    ArcGIS Engine ArcGIS-1021-E-SO12-Patch-linux.tar CE9EC2BBC0854125F69FD0BA2B4D3716
         
    ArcGIS for Server ArcGIS-1021-S-SO12-Patch-linux.tar 5085B18BB0B64125C6DBF50214FD560F
         

  2. Make sure you have write access to your ArcGIS installation location, and that no one is using ArcGIS.

  3. Extract the specified tar file by typing:

    % tar -xvf ArcGIS-1021-<product>-SO12-Patch-linux.tar

  4. Start the installation by typing:

    % ./applypatch

    This will start the dialog for the menu-driven installation procedure. Default selections are noted in parentheses ( ). To quit the installation procedure, type 'q' at any time.

  5. After the installation procedure has finished, complete the Upgrade a geodatabase section.

Upgrade a geodatabase


A geodatabase upgrade may be required after applying this patch. To upgrade the geodatabase, follow the instructions in the help section specific to your database management system:

Oracle

Note: ArcGIS clients connecting to an Oracle 12.2.0.1 database must use Oracle 11.2.0.4 or newer client.



Patch Updates

Check the Patches and Service Packs page periodically for the availability of additional patches. New information about this patch will be posted here.

How to identify which ArcGIS products are installed

To determine if the product(s) for this ArcGIS patch are installed, choose the appropriate operating system version of the PatchFinder utility for your environment and run it from your local machine. PatchFinder will list all core ArcGIS products, hot fixes, and patches installed on your local machine.

Getting Help

Domestic sites, please contact Esri Technical Support at 1-888-377-4575, if you have any difficulty installing this patch. International sites, please contact your local Esri software distributor.