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Bug

When the drive that ArcGIS Data Store is installed on runs out of disk space, a configuration file can get corrupted and cause backups to fail.

Last Published: June 20, 2017 Portal for ArcGIS
Bug ID Number BUG-000105166
SubmittedMay 15, 2017
Last ModifiedJune 11, 2020
Applies toPortal for ArcGIS
Version found10.5
Version Fixed10.5.1
StatusFixed

Description

If the drive on which ArcGIS Data Store is installed runs out of disk space, a local data store configuration file can be corrupted. Consequently, backups for the relational data store may fail.

Evaluating the following symptoms can indicate that a corruption has occurred:

  • The output of running the Describedatastore command shows a missing owning system URL.
    Owning system URL.........""   
  • The Listadminusers command shows the Database Repl User as "repuser" instead of "dsrepuser", and the "sde" user shows the password to be "sde".
    Admin users for relational data store ds_abcd1234
    =================================================
    Database Admin User.... adm_32ret / tT30!bYk22jF
    Database Repl User..... repuser / repuser
    GDB Admin User......... sde / sde   
  • The Listmanageduser command does not return any users.
    Managed user for relational data store ds_abcd1234
    =======================================================
    UserName     Password       Database   
  • Data store backups fail with the following error.
    Error encountered: Failed to generate a token for the user.   

Cause

This issue is associated with a known bug, BUG-000105166, which has been resolved with ArcGIS Data Store 10.5.1.

Workaround

The above symptoms occur primarily with ArcGIS Data Store 10.4.1; however, this may also occur with version 10.5 if the data store was upgraded from 10.4.1 while in the corrupted state.​

If this issue is encountered, backups fail, and commands return the results described above, do not attempt to register the relational data store. Please contact Esri Technical Support (for customers in the United States) or your Esri distributor (for customers outside the United States) to resolve this issue.

Steps to Reproduce

Bug ID: BUG-000105166

Software:

  • Portal for ArcGIS

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