English
Bug Number BUG-000100055
Submitted Oct 12, 2016
Modified Sep 12, 2019
Severity Medium
Applies To ArcGIS Online
Version Found 4.3
Prog Language N/A
Server Platform Windows 7.0 64 Bit
Client Platform Windows 7.0 64 Bit
Database N/A
Locale N/A
Status Implemented
Version Fixed 4.4
SP Fixed

Bug BUG-000100055

Synopsis

Unable to access the settings tab for ArcGIS Online items with stored credentials and limited usage when the referrer URLs do not include the ArcGIS Online Organization URL.


Additional Information

N/A


Alternate Solution

1. Create a new Item ID:

a. Add a new item and include the ArcGIS Online Organization URL while limiting the usage for the new item.

b. Delete the old item.


2. Maintain the original item ID.


Please note that it is not a recommended workflow due to the risks involved and it is not supported by ESRI technical Support


a. Add a new item and include the ArcGIS Online Organization URL while limiting the usage for the new item.

b. Sign into <a href="https://ago-assistant.esri.com" target="_blank">https://ago-assistant.esri.com</a>/.

c. Click on the 'I want to' drop-down menu > View an Item's JSON.

d. View the JSON for old item and note the Item ID.

f. View the JSON for new item and note the Item ID.

g. While viewing the JSON for the new item, click on the Edit Icon. Replace the ID in new item’s JSON with the old item’s ID.

h. Click Save.

i. Reload the page. Note that the original IDs are still displayed for each item while viewing the JSON within ArcGIS Online Assistant. Furthermrore, while opening the item details in ArcGIS Online, the item IDs in the URL remain the same for both items. The item details of the old item get updated using the new item's details. The settings tab now loads for the old item as well as the new item.

j. Update the limit usage settings for the old item to include the ArcGIS Online Organization URL.