English
Bug Number BUG-000092891
Submitted Dec 09, 2015
Modified Jun 11, 2020
Severity Medium
Applies To ArcSDE/Enterprise Geodatabase
Version Found 10.2
Prog Language N/A
Server Platform
Client Platform
Database N/A
Locale N/A
Status Implemented
Version Fixed 10.1
SP Fixed N/A

Bug BUG-000092891

Synopsis

The following error is returned: "One or more layers failed to draw: An invalid SQL statement was used" after applying a definition query on a joined feature class in an ArcSDE 10.2.x Oracle geodatabase, connected with a three-tier connection in ArcGIS Desktop 10.0 SP5.


Additional Information

Issue does not occur at ArcGIS DT 10.1 and also is not reproducible using direct connections. Please contact Support services if this issue is still being encountered in a current version.


Alternate Solution

Use the default connection type for database connections (direct connect).