English
Be The First To Get Support Updates
Want to know about the latest technical content and software updates?

Problem: ArcGIS Pro fails to open with the following error, “To run this application, you must install missing frameworks for .NET.”

Description

Launching ArcGIS Pro 3.0.3 and subsequent 3.0.x patch versions returns the following error:

 “To run this application, you must install missing frameworks for .NET. Would you like to download it now?”
29200a.png

Cause

ArcGIS Pro 3.0.3 and subsequent 3.0.x patch versions require a minimum of Microsoft .NET Desktop Runtime 6.0.5 – Windows x64, as indicated in the System Requirements. If the machine has .NET 7.x.x installed without the minimum required version from the .NET 6 family installed, this error is received.

Solution or Workaround

Download and install the latest available version of Microsoft .NET 6.x.x Desktop Runtime – Windows x64 from Microsoft: Download .NET 6.0, as shown in the image below.

29200c.png

Related Information

Last Published: 1/11/2023

Article ID: 000029200