English
Be The First To Get Support Updates
Want to know about the latest technical content and software updates?

Error: Scene Layer has an incompatible vertical coordinate system. The height model (ellipsoidal) must match that of the scene (gravity-related-height)

Error Message

Attempts to add a scene layer to a scene in ArcGIS Online Scene Viewer fail, and the following error is returned:

Error:
<Layer_Name> - <Layer_Name> cannot be added
Scene Layer has an incompatible vertical coordinate system. The height model (ellipsoidal) must match that of the scene (gravity-related-height).
The error message when adding the scene layer to ArcGIS Online Map Viewer

Cause

This is an expected behavior when an unsupported Z coordinate system is used to create the feature. This error can be related to the following warning when publishing the feature layer to ArcGIS Online, ArcGIS Pro: 24090: Ellipsoidal vertical coordinate systems may draw incorrectly.

Solution or Workaround

Change the coordinate system of the scene in ArcGIS Pro before publishing to ArcGIS Online.

  1. In ArcGIS Pro, right-click the scene layer and select Properties.
Right-click scene layer and select properties
  1. Click Coordinate Systems and click Current Z.
Map Properties window with Current Z selected
  1. Under Z Coordinate Systems Available, change the coordinate system to <None> or to a supported coordinate system. There are two supported vertical coordinate systems: ellipsoidal and gravity-based system, for example, EGM2008 or EGM1996.
Map Properties window with Current Z as None
  1. Share the feature as a web layer. Refer to ArcGIS Pro: Share a web feature layer for more information.
Note:
When clicking Analyze before publishing, ensure the 24090 warning is not returned.

Related Information

Last Published: 12/6/2022

Article ID: 000028883

Software: ArcGIS Online Current ArcGIS Pro 3.0.3, 3.0.2, 3.0.1, 3.0, 2.9.5, 2.9.4, 2.9.3, 2.9.2, 2.9.1, 2.9, 2.8.8, 2.8.7, 2.8.6, 2.8.5, 2.8.4, 2.8.3, 2.8.2, 2.8.1, 2.8, 2.7.7, 2.7.6, 2.7.5, 2.7.4, 2.7.3, 2.7.2, 2.7.1, 2.7