ArcGIS Pro crashes and the message “The application cannot continue because an invalid certificate was detected.”
Description
ArcGIS Pro crashes and the message “The application cannot continue because an invalid certificate was detected.” is displayed by the Error Report processor.
Cause
Software crashes can happen for a variety of reasons – coding errors, bad data, incompatible libraries, etc. When an error is detected, ArcGIS Pro has the ability to catch the error and provide the user with an opportunity to submit an error report to Esri for analysis through the Esri User Experience Improvement program.
There is a category of error that can be caused by one or more modified libraries in the ArcGIS Pro install where the library is no longer supportable and is incompatible with the software. If you receive the message “Invalid certificate detected on <library>” one of these situations has been identified . You can check the following libraries to see if one or more may have been replaced by an unsupported version.
ArcGIS Pro 3.0.3
Library Name | Version Number | Build Date | Expected Size | Expected SHA-256 |
---|---|---|---|---|
AfCore.dll | 13.0.0.36057 | November 2, 2022 | 5.35 MB (5,616,480 bytes) | D1A260DE355853C79C2F185D14AA1E9B7E60B2A3B026BEAA7209868906FF1355 |
AfCore_libFNP.dll | 13.0.3.36057 | November 2, 2022 | 9.59 MB (10,060,640 bytes) | 35874588B9E36D6F0D921B9A0F73F2FDFB90882E971E8E35FD494C26BA7FB725 |
SoftwareAuthorizationPro.exe | 13.9.2.29486 | November 2, 2022 | 7.09 MB (7,437,664 bytes) | FE65A8F964D31BEF5D8ACE4F1F0904F7A161CFCADE28527CCAC38776AE4F5134 |
SoftwareAuthorizationPro_libFNP.dll | 13.9.2.29486 | November 2, 2022 | 9.59 MB (10,060,640 bytes) | F8E3C98A320081765523AC7202FBCC0370D5C0ECE3D13B939F1A1E1188192EF6 |
AoInitializer.dll | 13.0.3.36057 | November 2, 2022 | 113 KB (116,064 bytes) | 4A42C9D94926842EBE4074C69F96CDB923D03C99955BEAF0E0890C890EC9469E |
ArcGISPro.exe | 13.0.3.36057 | November 2, 2022 | 387 KB (397,152 bytes) | CCC8BC3B9292BE1CACA52FC86144B9357DE06580A32AD1788E1BEEC3FC0D6595 |
Solution or Workaround
Use a tool to generate a SHA-256 hash for the library in question. Here’s an example of how to do it within Windows PowerShell with the Get-FileHash command:
PS C:\> Get-FileHash "C:\Program Files\ArcGIS\Pro\bin\AfCore.dll" Algorithm Hash Path SHA-256 D1A260DE355853C79C2F185D14AA1E9B7E60B2A3B026BEAA7209868906FF1355 C:\Program Files\ArcGIS\Pro\b...
If the generated SHA-256 hash matches the expected SHA-256 in the above table, then the library should be an unmodified and supported version. If the generated SHA-256 hash does not match the expected SHA-256 hash in the above table, then it is possible you have an unsupported library.
If you have installed software from another party that has updated any of these libraries, it is recommended that you uninstall that software and ensure that your ArcGIS Pro install has rolled back to a known state with valid libraries, or reinstall Pro from the original Esri software install files.
If you have received an installation of ArcGIS Pro with these modified/unsupported libraries already in place, you may want to contact your software supplier or corporate Information Technology department to report the problem – These files may have been modified from the original software distribution.
Related Information
Last Published: 11/28/2022
Article ID: 000028572
Software: ArcGIS Pro 3.0.3, 3.0.2, 3.0.1, 3.0