Description
During an upgrade from ArcGIS Enterprise on Kubernetes from 10.9.1 to 11.0, an organization may encounter an unrecoverable failure that is due to corrupted service data.
Cause
When a 10.9.1 ArcGIS Enterprise on Kubernetes organization published hosted map services using large datasets (those greater than 50 MB), the supporting data that was copied to system-managed data stores may have become corrupt.
- This issue is reproducible for map services that are running in shared or dedicated mode.
- This issue is not reproducible for other hosted service types such as feature, tile, or vector tile, where data was copied to the server when published.
- This issue is not reproducible for services that reference registered data.
Solution or Workaround
Before performing an upgrade from 10.9.1 to 11.0, ArcGIS Enterprise on Kubernetes organizations must follow these steps to work around the issue:
- Use ArcGIS Enterprise Manager to stop all hosted map services (those which copied data to system-managed data stores when published).
- Apply the 11.0 software upgrade using ArcGIS Enterprise Manager or ArcGIS Enterprise Administrator API.
- After the upgrade has been applied successfully, start the services that were stopped in Step 1.
- Use Map Viewer to validate that the upgraded hosted map services render as expected.
- If the service data displays correctly, the services were upgraded as expected.
- If the data does not display correctly or returns an error that it cannot be added to the map for example, delete the map service, and re-create it again at version 11.0