English
Be The First To Get Support Updates
Want to know about the latest technical content and software updates?

Error: Drone2Map "Invalid client_id Error 400" error

Error Message

Note:
This document is not comprehensive, there may be additional causes for this issue.

When starting Drone2Map 2022.1 or newer using a Named User License from an ArcGIS Enterprise portal, the following error may be returned:

"Invalid client_id Error: 400."

This error is common with authentication issues, however this is not always the case. This article discusses one of the potential causes and a fix for the issue.

Note: 
This article assumes that the Named User License has already been properly imported into the ArcGIS Enterprise portal and ArcGIS License Manager. If this has not been done, do so before following this workflow.
image.png

Cause

The version of ArcGIS Drone2Map is likely not compatible with the license being used.

Solution or Workaround

The ArcGIS Drone2Map license name should correlate with the software version mentioned below:

License nameVersion used
ArcGIS Drone2MapArcGIS Drone2Map 2.3.3. or earlier
ArcGIS Drone2Map StandardArcGIS Drone2Map 2022.1 or later
ArcGIS Drone2Map AdvancedArcGIS Drone2Map 2022.1 or later

For example:

  • If ArcGIS Drone2Map 2.3.3 or earlier is installed, the name of the license should be ArcGIS Drone2Map.
  • If ArcGIS Drone2Map 2022.1 or later is installed, the name of the license should be ArcGIS Drone2Map Standard or ArcGIS Drone2Map Advanced.

If for any reason the desired version of ArcGIS Drone2Map cannot be used due to an incompatible license, the Customer Service Representative for the My Esri organization may need to be contacted.

Related Information

Last Published: 12/27/2022

Article ID: 000028404

Software: ArcGIS Drone2Map 2022.1.2, 2022.1.1, 2022.1, 2.3.3, 2.3.2, 2.3.1, 2.3, 2.2.1, 2.2, 2.1.1, 2.1, 2.0.2, 2.0.1, 2.0, 1.3.2, 1.3.1, 1.3, 1.2, 1.1, 1.0.1, 1.0