ERROR

The portal has been initialized and configured but is not accessible. The internal portal database does not appear to be running or accepting connections

Last Published: October 1, 2021

Error Message

Unable to access the portal home page with the following severe error message returned in the portal logs:

Error:
The portal has been initialized and configured but is not accessible. The internal portal database does not appear to be running or accepting connections.

This error message is returned in the following scenarios:

  • Upgrading to a newer version of Portal for ArcGIS.
  • Restarting the portal service.
  • The server is improperly shut down. For example, during an outage.
  • After failing to publish content to Portal for ArcGIS.

Cause

  • Portal for ArcGIS cannot access the data store as the data store is in read-only mode due to insufficient disk space.
  • Insufficient RAM on the portal machine. Refer to Portal for ArcGIS: Hardware requirements for more information.
  • The service account specified when configuring Portal for ArcGIS is different from the service account specified when configuring ArcGIS Server and ArcGIS Data Store. All components in ArcGIS Enterprise must use the same service accounts.
  • Portal for ArcGIS is improperly configured or federated.

Solution or Workaround

Depending on the cause, use one of the following solutions to resolve the issue.

Ensure there is sufficient disk space and RAM on the portal machine

  1. Increase the disk space of the ArcGIS Data Store machine. For more information, refer to ArcGIS Enterprise: Disk space requirements.
  2. Change the relational data store setting from read-only to read-write mode. Refer to the solution section of this article, Error: Failed to create new feature(s). General Function Failure [database error has occured.] for more information.

Configure Portal for ArcGIS to use the same service account ArcGIS Server and ArcGIS Data Store

Portal for ArcGIS, ArcGIS Server and ArcGIS Data Store can be configured to use either a Domain account, local account or a group managed service account (gMSA). The same service account type must be used for all components in ArcGIS Enterprise.

To change the service account used in Portal for ArcGIS, refer to ArcGIS Enterprise: Change the Portal for ArcGIS account.

To change the service account used in ArcGIS Server, refer to ArcGIS Enterprise: Changing the ArcGIS Server account.

To change the service account used in ArcGIS Data Store, refer to Portal for ArcGIS: ArcGIS Data Store account.

Restore the portal to a previous working instance using the webgisdr backup tool

A previous working instance of the portal can be restored using the webgisdr tool. Refer to Portal for ArcGIS: Restore ArcGIS Enterprise.

Uninstall and reinstall Portal for ArcGIS

Warning:   
The instructions below include making changes to essential parts of the ArcGIS Enterprise deployment. Esri recommends performing a backup of the ArcGIS Enterprise machine, including the registry, before proceeding. Esri cannot guarantee results from incorrect modifications while following these instructions. Exercise caution. Consult a qualified computer systems professional if necessary.
  1. Perform a backup of the portal content directory, and save the backup in a temporary location.
  2. Uninstall Portal for ArcGIS. For steps, refer to Microsoft: Uninstall or remove apps and programs in Windows 10.
  3. Reinstall the previous version of Portal for ArcGIS. For steps, refer to ArcGIS Enterprise: Installing Portal for ArcGIS.
  4. Once the installation is complete, create the Portal for ArcGIS site by pointing it to the original content directory location.

Article ID:000026498

Software:
  • Portal for ArcGIS

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